Modify

Opened 7 years ago

Closed 6 years ago

Last modified 21 months ago

#5449 closed defect (fixed)

apcupsd failed to compile under trunk version with gcc 3.4.6 over (works fine with gcc > 3.4.6)

Reported by: guillermo@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description (last modified by florian)

touch /home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/.configured_
make -C /home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2 DESTDIR="/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/ipkg-install" LD="mipsel-openwrt-linux-uclibc-gcc" all install
make[3]: Entering directory `/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2'
make[4]: Entering directory `/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/src'
make[5]: Entering directory `/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/src/lib'
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apcconfig.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apcerror.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apcevents.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apcexec.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apcfile.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apclibnis.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apclock.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apclog.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apcsignal.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include apcstatus.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include asys.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include newups.c
mipsel-openwrt-linux-uclibc-g++ -c -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/geryon/programacion/waveFlight/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/include -fno-exceptions -fno-rtti -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -Wall -I/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/include md5.c
md5.c:132: error: variable or field `md5_process' declared void
md5.c:132: error: `md5_state_t' was not declared in this scope
md5.c:132: error: `pms' was not declared in this scope
md5.c:132: error: expected primary-expression before "const"
md5.c:133: error: initializer expression list treated as compound expression
md5.c:133: error: expected ,' or ;' before '{' token
md5.c:313: error: variable or field `md5_init' declared void
md5.c:313: error: `md5_state_t' was not declared in this scope
md5.c:313: error: `pms' was not declared in this scope
md5.c:314: error: expected ,' or ;' before '{' token
md5.c:323: error: variable or field `md5_append' declared void
md5.c:323: error: `md5_state_t' was not declared in this scope
md5.c:323: error: `pms' was not declared in this scope
md5.c:323: error: expected primary-expression before "const"
md5.c:323: error: expected primary-expression before "int"
md5.c:324: error: initializer expression list treated as compound expression
md5.c:324: error: expected ,' or ;' before '{' token
md5.c:361: error: variable or field `md5_finish' declared void
md5.c:361: error: `md5_state_t' was not declared in this scope
md5.c:361: error: `pms' was not declared in this scope
md5.c:361: error: `md5_byte_t' was not declared in this scope
md5.c:362: error: initializer expression list treated as compound expression
md5.c:362: error: expected ,' or ;' before '{' token
md5.c:132: warning: 'md5_process' defined but not used
make[5]: * [md5.o] Error 1
make[5]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/src/lib'
make[4]:
* [all-subdirs] Error 2
make[4]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/src'
make[3]: * [all-subdirs] Error 2
make[3]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2'
make[2]:
* home/geryon/programacion/waveFlight/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/apcupsd-3.14.2/.built Error 2
make[2]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/feeds/packages/net/apcupsd'
make[1]: * [package/feeds/packages/apcupsd/compile] Error 2
make[1]: Leaving directory `/home/geryon/programacion/waveFlight/trunk'
make:
* [package/apcupsd/compile] Error 2

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by florian

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this error.

comment:2 Changed 6 years ago by lars

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:3 Changed 6 years ago by lars

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r19784

comment:4 Changed 21 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.