Modify

Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#5594 closed enhancement (fixed)

Please add support for RTA1025W_16 board (BCM6348)

Reported by: fa310580@… Owned by: developers
Priority: normal Milestone:
Component: kernel Version:
Keywords: RTA1025W_16 BCM6348 NB6Plus4W 531B Cc:

Description

Hi,
if it needs I can give you additional dumps or infos.

Prototypes of this board are:

  • Dynalink RTA1025W
  • NetComm NB6Plus4W
  • ZTE ZXDSL 531B
  • may be Siemens SL2-141
  • may be Huawei Echolife HG 520

some logs:

CFE version 1.0.37-6.8.5 for BCM96348 (32bit,SP,BE)
Build Date: Tue Jan 2 19:42:28 CST 2007 (michaelc)

Boot Address 0xbfc00000

Flash Config: CS0(1fc00009,1f),Base(bfc00000),Size(4MB)

...

Firmware Version: 3.63u
ADSL Driver Version: A2pB023k.d20h
Wireless Driver Version: 3.131.35.6.cpe2.0a

BusyBox v1.00 (2007.11.13-06:57+0000) Built-in shell (msh)
Enter 'help' for a list of built-in commands.

cat /proc/cpuinfo

system type : RTA1025W_16
processor : 0
cpu model : BCM6348 V0.7
BogoMIPS : 239.20
wait instruction : no
microsecond timers : yes
tlb_entries : 32
extra interrupt vector : yes
hardware watchpoint : no
VCED exceptions : not available
VCEI exceptions : not available

cat /proc/meminfo

MemTotal: 14160 kB
MemFree: 580 kB
Buffers: 812 kB
Cached: 7444 kB
SwapCached: 0 kB
Active: 2556 kB
Inactive: 6716 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 14160 kB
LowFree: 580 kB
SwapTotal: 0 kB
SwapFree: 0 kB
Dirty: 0 kB
Writeback: 0 kB
Mapped: 2552 kB
Slab: 2564 kB
Committed_AS: 3316 kB
PageTables: 244 kB
VmallocTotal: 1048560 kB
VmallocUsed: 1376 kB
VmallocChunk: 1046800 kB

Attachments (1)

rtalink_1025W_16.patch (613 bytes) - added by Daniel Dickinson <crazycshore@…> 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by Daniel Dickinson <crazycshore@…>

It might just need a suitable image tag. Can you provide ODM firmware images and source code?

comment:2 Changed 7 years ago by fa310580@…

Despite my tries I can't find source code, but I have a number of firmware files from different sources.
Can I attach it or just post link?

comment:3 Changed 7 years ago by anonymous

For example, firmware file from NetComm NB6Plus4W excellent works on ZTE ZXDSL 531B here http://www.netcomm.com.au/__data/assets/file/0017/55052/cfe-nb6plus4w-v364y_a2pb025c.bin

Changed 7 years ago by Daniel Dickinson <crazycshore@…>

comment:4 Changed 7 years ago by Daniel Dickinson <crazycshore@…>

Can you try the above patch? Based on that firmware I think it should work. It was just a matter of setting the board_id in the call to create the firmware image in the image Makefile. It looks the same as a BT Voyager from an imagetag perspective.

comment:5 Changed 7 years ago by fa310580@…

Thank you, Daniel!

I beginner at OpenWRT build, so I need some help:

  1. Do I have to edit board name target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c ?
  2. I have Linux installed on virtual machine (VirtualBox) booting from livecd http://download.nicksoft.info/linux/backuplivecd/backlivecd.iso

How can I build openwrt firmware on it?

May be some instruction? ))

comment:6 Changed 7 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Applied in [17058], thanks !

comment:7 Changed 7 years ago by Daniel Dickinson <crazycshore@…>

You should read the wiki and the docs.

Take a look at http://openwrt.org and start browsing. There's enough to learn. If you've never used linux before you need to learn that too, and there are lots of sites for that. I'm afraid if you want more specific help I need more specific questions. And you should post to the forums for that.

comment:8 Changed 7 years ago by fa310580@…

Thank you.
I've just build development branch svn://svn.openwrt.org/openwrt/trunk/ on ubunta 9 desktop on WMPlayer. All compilled witout error.
But after uploading firmware into router it's seems like it don't boot...
I tried to reset it - no results. Then I connect terminal wire to COM (null-modem) (115200-8-N-1) after power on it sends some garbage and hangs.
It seems there is no JTAG connector on-board http://i034.radikal.ru/0908/6d/8b221fbda472.jpg

comment:9 Changed 7 years ago by Daniel Dickinson <crazycshore@…>

If it's total garbage (i.e. not even CFE text), I'd suggest you try different speeds until you find one that works, starting at 9600 8N1

If there is some useful text, please post it.

comment:10 Changed 7 years ago by Daniel Dickinson <crazycshore@…>

Also, for the terminal, have you used a level shifter (TTL to RS232)

comment:11 Changed 7 years ago by anonymous

It's really garbage... At other speeds there is no recieved bytes at all.

No, it's simple 3-wire (TX,RX,GND) null-modem cable.

Does It's possible to buy TTL to RS232 shifter? I'am from Russia. :O)

comment:13 Changed 7 years ago by anonymous

Thank You a lot, Daniel!

I repair broken unit by pin 10 trick as discribed here http://wl500g.info/showthread.php?t=1606&highlight=pin and feel it by last ODM firmware.

As I discovered by myself that Open-WRT by now have no adsl driver for BCM63xx boards, I don't see any reasons to have it on my ADSL-router. :O(

Sorry...

comment:14 Changed 7 years ago by _Pashtet_{dog}inbox.ru

Hi All!
I have Echolife HG520 (old) on board RTA1025W (and many Russia users =))
Original firmware not work normal... =(((
...I wait 2 years when original fixed firmware is published…. I don’t wait more…. ]:-)
Maybe WRT projects can help me?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.