Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#5595 closed defect (worksforme)

md5.h clash hostapd

Reported by: anonymous Owned by: nico
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Kamikaze 8.09
Keywords: Cc: matson@…

Description

hostapd won't compile after "make menuconfig" and "make" due to using wrong md5.h.

Output:

make[4]: Entering directory `/home/myname/openwrt/8.09/build_dir/mipsel/hostapd-0.6.6/hostapd.default/hostapd'

mipsel-linux-uclibc-gcc -Os -pipe -mips32 -mtune=mips32 
-funit-at-a-time -fhonour-copts \
-I/home/myname/openwrt/8.09/staging_dir/mipsel/usr/include/madwifi \
-I/home/myname/openwrt/8.09/staging_dir/mipsel/usr/include \
-DHOSTAPD_DUMP_STATE -I../src -I../src/crypto -I../src/utils \
-I../src/common -DCONFIG_CTRL_IFACE -DCONFIG_CTRL_IFACE_UNIX \
-DCONFIG_IAPP -DCONFIG_RSN_PREAUTH -DCONFIG_PEERKEY \
-DCONFIG_DRIVER_HOSTAP -DCONFIG_DRIVER_WIRED -DEAP_MD5 -DEAP_TLS \ 
-DEAP_PEAP -DEAP_TTLS -DEAP_MSCHAPv2 -DEAP_GTC -DEAP_SERVER \
-DEAP_TLS_FUNCS -DPKCS12_FUNCS -DINTERNAL_SHA256 \
-DCONFIG_NO_FIPS186_2_PRF -DCONFIG_NO_T_PRF -DCONFIG_IPV6  \
-c -o ../src/common/wpa_common.o ../src/common/wpa_common.c

../src/common/wpa_common.c: In function `wpa_eapol_key_mic':
../src/common/wpa_common.c:57: error: `MD5_MAC_LEN' undeclared (first use in this function)
../src/common/wpa_common.c:57: error: (Each undeclared identifier is reported only once
../src/common/wpa_common.c:57: error: for each function it appears in.)
make[4]: *** [../src/common/wpa_common.o] Error 1

Uses md5.h from: -I/home/myname/openwrt/8.09/staging_dir/mipsel/usr/include

Should use md5.h from: -I../src/crypto

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by nico

  • Owner changed from developers to nico

comment:2 Changed 7 years ago by nico

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce the bug: there is no 'md5.h' file in './staging_dir/.../usr/include' after a full build with all packages enabled.

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.