Modify

Opened 8 years ago

Closed 8 years ago

#5622 closed defect (fixed)

ip-up bug

Reported by: hollari@… Owned by: nico
Priority: normal Milestone: Kamikaze 8.09.2
Component: packages Version:
Keywords: Cc:

Description

Hi !
There seems to be a bug in /etc/ppp/ip-up.
If there are empty parameters, the following parameters are passed incorrectly to the scripts under /etc/ppp/ip-up.d.
e.g. the ipparam is found often under $5 and not $6.
I have solved this like follows :

[ -x "$SCRIPT" ] && "$SCRIPT" $@

[ -x "$SCRIPT" ] && "$SCRIPT" "$@"

The bug seems to be there in Whiterussian (all Versions) and Kamikaze (seen so far in 8.09.1)

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by nico

  • Milestone changed from Kamikaze to Kamikaze 8.09.2
  • Owner changed from developers to nico
  • Status changed from new to assigned

comment:2 Changed 8 years ago by nico

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [17763], thanks!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.