Modify

Opened 7 years ago

Closed 7 years ago

Last modified 22 months ago

#5657 closed defect (worksforme)

r17201 - usb seems to be not working at all on wgt634u

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: mipsel, brcm47xx, wgt634u, usb Cc:

Description

The usb seems to be not working at all. Neither insertion nor removal any of usb-audio or usb-mass-storage device isn't recognizable and doesn't produce any information in the log.

additional installed modules: kmod-usb-ohci, kmod-usb2, kmod-usb-audio, kmod-usb-storage

bootlog:

Linux version 2.6.28.10 (...) (gcc version 4.3.3 (GCC) ) #1 Sun Aug 9 16:54:40 CEST 2009
CPU revision is: 00029007 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x05, vendor 0x4243)
ssb: Core 1 found: Fast Ethernet (cc 0x806, rev 0x06, vendor 0x4243)
ssb: Core 2 found: IPSEC (cc 0x80B, rev 0x01, vendor 0x4243)
ssb: Core 3 found: USB 1.1 Hostdev (cc 0x808, rev 0x02, vendor 0x4243)
ssb: Core 4 found: PCI (cc 0x804, rev 0x08, vendor 0x4243)
ssb: Core 5 found: MIPS 3302 (cc 0x816, rev 0x01, vendor 0x4243)
ssb: Core 6 found: MEMC SDRAM (cc 0x80F, rev 0x00, vendor 0x4243)
ssb: Initializing MIPS core...
ssb: core 0x0800, irq : 2(S)  3* 4  5  6  D  I 
ssb: core 0x0806, irq : 2(S)  3  4* 5  6  D  I 
ssb: core 0x080b, irq : 2(S)  3  4  5* 6  D  I 
ssb: core 0x0808, irq : 2(S)  3  4  5  6* D  I 
ssb: core 0x0804, irq : 2(S)* 3  4  5  6  D  I 
ssb: core 0x0816, irq : 2(S)* 3  4  5  6  D  I 
ssb: core 0x080f, irq : 2(S)  3  4  5  6  D  I*
ssb: set_irq: core 0x0806, irq 4 => 4
ssb: set_irq: core 0x080b, irq 5 => 2
ssb: set_irq: core 0x0804, irq 2 => 5
ssb: after irq reconfiguration
ssb: core 0x0800, irq : 2(S)  3* 4  5  6  D  I 
ssb: core 0x0806, irq : 2(S)  3  4* 5  6  D  I 
ssb: core 0x080b, irq : 2(S)* 3  4  5  6  D  I 
ssb: core 0x0808, irq : 2(S)  3  4  5  6* D  I 
ssb: core 0x0804, irq : 2(S)  3  4  5* 6  D  I 
ssb: core 0x0816, irq : 2(S)* 3  4  5  6  D  I 
ssb: core 0x080f, irq : 2(S)  3  4  5  6  D  I*
early_nvram_init: WGT634U NVRAM found.
ssb: Sonics Silicon Backplane found at address 0x18000000
Swapping serial ports!
Serial init done.
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
Primary instruction cache 8kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 4kB, 2-way, VIPT, no aliases, linesize 16 bytes
PID hash table entries: 128 (order: 7, 512 bytes)
console [ttyS0] enabled
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Memory: 29548k/32768k available (2211k kernel code, 3220k reserved, 434k data, 136k init, 0k highmem)
Calibrating delay loop... 198.65 BogoMIPS (lpj=397312)
Mount-cache hash table entries: 512
net_namespace: 480 bytes
NET: Registered protocol family 16
ssb: PCIcore in host mode found
PCI: Fixing up bridge 0000:00:00.0
PCI: Fixing up device 0000:00:00.0
PCI: Fixing latency timer of device 0000:00:00.0 to 168
pci 0000:00:02.0: PME# supported from D0 D1 D2 D3hot
pci 0000:00:02.0: PME# disabled
pci 0000:00:02.1: PME# supported from D0 D1 D2 D3hot
pci 0000:00:02.1: PME# disabled
pci 0000:00:02.2: PME# supported from D0 D1 D2 D3hot
pci 0000:00:02.2: PME# disabled
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
NET: Registered protocol family 1
detected lzma initramfs
initramfs: LZMA lc=1,lp=2,pb=2,origSize=512
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 57
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver2 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250: ttyS1 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250.0: ttyS0 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250.0: ttyS1 at MMIO 0xb8000300 (irq = 3) is a 16550A
b44.c:v2.0
eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:09:5b:f8:b2:c1
flash init: 0x1c000000 0x02000000
Physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank
 Intel/Sharp Extended Query Table at 0x0031
Using buffer write method
cfi_cmdset_0001: Erase suspend on write enabled
Flash device: 0x800000 at 0x1fc00000
bootloader size: 655360
Creating 4 MTD partitions on "Physically mapped flash":
0x00000000-0x000a0000 : "cfe"
0x000a0000-0x007e0000 : "linux"
0x0017f800-0x007e0000 : "rootfs"
mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2E0000, len=500000 
0x002e0000-0x007e0000 : "rootfs_data"
0x007e0000-0x00800000 : "nvram"
BCM47xx Watchdog Timer enabled (30 seconds, nowayout)
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 136k freed
Please be patient, while OpenWrt loads ...
- preinit -
Press CTRL-C for failsafe
diag: Detected 'Netgear WGT634U'
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
roboswitch: Probing device eth0: found!
b44: eth0: powering down PHY
switching to jffs2
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
- init -

Please press Enter to activate this console. b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
device eth0.0 entered promiscuous mode
device eth0 entered promiscuous mode
br-lan: topology change detected, propagating
br-lan: port 1(eth0.0) entering forwarding state
ocf: module license 'BSD' taints kernel.
Sentry5(tm) ROBOGateway(tm) IPSec Core at IRQ 2
ubsec_ssb: DES 3DES AES128 AES192 AES256 MD5_HMAC SHA1_HMAC
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ip_tables: (C) 2000-2006 Netfilter Core Team
Driver 'sd' needs updating - please use bus_type methods
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
PCI: Enabling device 0000:00:02.2 (0000 -> 0002)
PCI: Fixing up device 0000:00:02.2
ehci_hcd 0000:00:02.2: EHCI Host Controller
ehci_hcd 0000:00:02.2: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:02.2: irq 5, io mem 0x40000000
ehci_hcd 0000:00:02.2: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: EHCI Host Controller
usb usb1: Manufacturer: Linux 2.6.28.10 ehci_hcd
usb usb1: SerialNumber: 0000:00:02.2
nf_conntrack version 0.5.0 (512 buckets, 2048 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
wlan: trunk
ath_hal: 2009-05-08 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, REGOPS_FUNC, XR)
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
wlan: mac acl policy registered
ath_pci: trunk
PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
PCI: Fixing up device 0000:00:01.0
Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_pci: wifi0: Atheros 5212: mem=0x40010000, irq=5
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
PCI: Enabling device 0000:00:02.0 (0000 -> 0002)
PCI: Fixing up device 0000:00:02.0
ohci_hcd 0000:00:02.0: OHCI Host Controller
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:02.0: irq 5, io mem 0x40020000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 1 port detected
usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: OHCI Host Controller
usb usb2: Manufacturer: Linux 2.6.28.10 ohci_hcd
usb usb2: SerialNumber: 0000:00:02.0
PCI: Enabling device 0000:00:02.1 (0000 -> 0002)
PCI: Fixing up device 0000:00:02.1
ohci_hcd 0000:00:02.1: OHCI Host Controller
ohci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 3
ohci_hcd 0000:00:02.1: irq 5, io mem 0x40021000
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 1 port detected
usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb3: Product: OHCI Host Controller
usb usb3: Manufacturer: Linux 2.6.28.10 ohci_hcd
usb usb3: SerialNumber: 0000:00:02.1
ohci_hcd ssb0:2: SSB OHCI Controller
ohci_hcd ssb0:2: new USB bus registered, assigned bus number 4
ohci_hcd ssb0:2: irq 6, io mem 0x18003000
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb4: Product: SSB OHCI Controller
usb usb4: Manufacturer: Linux 2.6.28.10 ssb-usb-ohci
usb usb4: SerialNumber: ssb0:2
hub 4-0:1.0: unable to enumerate USB device on port 1
usbcore: registered new interface driver snd-usb-audio
usb 4-2: new low speed USB device using ohci_hcd and address 3
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb 4-2: device descriptor read/64, error -62
usb 4-2: device descriptor read/64, error -62
usb 4-2: new low speed USB device using ohci_hcd and address 4
usb 4-2: device descriptor read/64, error -62
usb 4-2: device descriptor read/64, error -62
usb 4-2: new low speed USB device using ohci_hcd and address 5
usb 4-2: device not accepting address 5, error -62
usb 4-2: new low speed USB device using ohci_hcd and address 6
usb 4-2: device not accepting address 6, error -62
hub 4-0:1.0: unable to enumerate USB device on port 2
usb 4-1: new low speed USB device using ohci_hcd and address 7
usb 4-1: device descriptor read/64, error -62
usb 4-1: device descriptor read/64, error -62
usb 4-1: new low speed USB device using ohci_hcd and address 8
usb 4-1: device descriptor read/64, error -62
usb 4-1: device descriptor read/64, error -62
usb 4-1: new low speed USB device using ohci_hcd and address 9
usb 4-1: device not accepting address 9, error -62
usb 4-1: new low speed USB device using ohci_hcd and address 10
usb 4-1: device not accepting address 10, error -62
hub 4-0:1.0: unable to enumerate USB device on port 1
hub 1-0:1.0: unable to enumerate USB device on port 1
hub 1-0:1.0: unable to enumerate USB device on port 1
hub 1-0:1.0: unable to enumerate USB device on port 1

Attachments (2)

dmesg-log.txt (30.7 KB) - added by anonymous 7 years ago.
dmesg output (with CONFIG_USB_DEBUG enabled)
ohci-ehci-registers-dump.txt (5.1 KB) - added by anonymous 7 years ago.
/sys/kernel/debug/{ohci|ehci}/registers dump

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by anonymous

dmesg output (with CONFIG_USB_DEBUG enabled)

Changed 7 years ago by anonymous

/sys/kernel/debug/{ohci|ehci}/registers dump

comment:1 Changed 7 years ago by anonymous

Let me know if any additional information I can provide could be helpful to track down the issue.

comment:2 Changed 7 years ago by florian

I think the issue is related to: target/linux/brcm47xx/patches-2.6.28/816-ssb_fix_irq_setup.patch

comment:3 Changed 7 years ago by dwrobel@…

Strange thing was that it worked from time to time especially when I connected the usb device via the usb hub which had a separate power supplier.

Deeper analysis has shown that it was a hardware problem, more precisely the coil L501 was broken and as a result the internal USB power switch couldn't power any connected device. Once it was replaced, USB started to work.

Sorry, for the confusion.
Issue can be closed.

comment:4 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.