Modify

Opened 7 years ago

Closed 6 years ago

Last modified 2 years ago

#5692 closed defect (fixed)

sysupgrade error with glibc and x86

Reported by: andrea <andrea@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: sysupgrade glibc Cc:

Description

I'm testing trunk version with glibc on a x86 board (PCEngines Alix). When I have tried an upgrade through LUCI interfaces and also with sysupgrade utility, the upgrade has failed and I have power off and on my devices.

The problem is due to glibc are missing in ramfs and I have solved it with the attached patch

Attachments (1)

firmware_upgrade.patch (526 bytes) - added by andrea <andrea@…> 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by andrea <andrea@…>

comment:1 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r19167

comment:2 Changed 6 years ago by anonymous

Note: the same fix is still missing for eglibc.

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.