Modify

Opened 7 years ago

Closed 7 years ago

Last modified 22 months ago

#5728 closed enhancement (duplicate)

add support for D-link DSL-2640U rev B2 (D-4P-W with BCM6348 V0.7)

Reported by: V Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:

Description

i have build openwrt for it from svn with some of 2009.08.12 revisions, flashed it with openwrt-D-4P-W-squashfs-bc310-cfe.bin via flashimage command from CFE.

it started to boot but immediately failed with:

Kernel panic - not syncing: unable to detect bcm963xx board

search on forums gave me pretty obscure results as
https://forum.openwrt.org/viewtopic.php?pid=91568#p91568
and https://forum.openwrt.org/viewtopic.php?id=21087

either way - you also can obtain source codes for this model via
ftp://dlink.ru/pub/ADSL/GPL_source_code/RU_DSL-2640U/RU_DSL-2640U_3-06-04-3C_GPL.tar.gz but make no mistake with different board with same name but revision D1

there is good info on this board in russian but with examples

i will try to experiment with newer revisions and write back if it succeedes, probably it only just needs some

$(call Image/Build/CFE,$(1),D-4P-W,6348,bc310,,bc310)

variation in target/linux/brcm63xx/image/Makefile

Attachments (1)

bootlog (6.1 KB) - added by V 7 years ago.
bootlog of proprietary firmware

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by V

bootlog of proprietary firmware

comment:1 Changed 7 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

You also need to define your board in arch/mips/bcm63xx/boards/board_bcm963xx.c.

comment:2 Changed 7 years ago by V

i have lost this hardware so, unfortunately, i will not be able to give future feedback or testing on that :(

will hope that other guys from openwrt's forum will join and get this to work.

comment:3 Changed 7 years ago by ip_saraj@…

This seems to be the same request as mine: https://dev.openwrt.org/ticket/5472

comment:4 Changed 7 years ago by florian

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #5472.

comment:5 Changed 6 years ago by anonymous

I have the same hardware and i have the same problem. Does anybody now how to fix it?

comment:6 Changed 5 years ago by LamuzNick

I am am excited too with this question where I can find more information on this question?

comment:7 Changed 5 years ago by LamuzNick

I apologise, there is an offer to go on other way.

comment:8 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.