Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#5749 closed defect (wontfix)

Atheros WLAN doesn't forward packets in client mode

Reported by: henning@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: other Version: Trunk
Keywords: Cc:

Description

I'm trying to use a D-Link DIR-300 in STA mode (WLAN client). The device uses an Atheros AR2317 SoC. I can send and receive data on the wired interface (switch) and I can send and receive data on the wireless interface. But as soon as I send data from a client connected to the wired interface to another node on the network reachable only via the wireless interface of the DIR-300, the DIR-300 goes into a disassociation/re-association loop with the AP it is connected to and thus traffic stops. The loop stops as soon as the traffic through the bridge stops.

If you need more information on the configuration etc., please let me know.

Attachments (0)

Change History (9)

comment:1 Changed 7 years ago by anonymous

Client mode does not work. It's broken by design.

comment:2 Changed 7 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

yes, bridging a client mode interface is indeed not supported.

comment:3 Changed 7 years ago by henning@…

Could you be so kind to give me more information on why bridging in client mode is not supported? Is OpenWRT configured in a way that the bridge does not work because OpenWRT is not meant to be used this way? Are there hardware limitations or bugs on the AR2317 platform which prevent the bridge from working in client mode? I would really like to see the bridge working in wireless client mode, so I would like to know whether is is a fixable problem. If this is beyond the scope of this bug report, feel free to reply to my email address that I used to report the problem.

comment:4 Changed 7 years ago by nbd

It's because 802.11 is not meant to be used in this way. An 802.11 client transmits 3 addresses on data frames: the BSSID, the destiation MAC and the MAC address of the client. What's important here is that the source MAC address of the packet is missing, and that's what makes this mode unsuitable for bridging.

comment:5 Changed 7 years ago by anonymous

So how an OS like DD-WRT has client bridge mode? How that works?

comment:6 Changed 7 years ago by nbd

through an ugly layer 2 nat hack

comment:7 Changed 6 years ago by anonymous

bridge with client mode also works in UBNT stock firmware

comment:8 Changed 6 years ago by jow

using the same ugly layer 2 hack

comment:9 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.