Opened 10 years ago

Closed 10 years ago

#580 closed defect (worksforme)

WL-HDD wrongly tried to dhcp on "wan" interface

Reported by: anonymous Owned by: developers
Priority: normal Milestone: 0.9/rc6
Component: base system Version:
Keywords: Cc:


Reflash brand new Asus WL-HDD with WhiteRussian RC5. Run "" to make sure nvram is tidy.

However after this you still have settings for "wan_*", even though the WL-HDD doesn't have a WAN port:

root@OpenWrt:/# nvram show | grep wan
size: 1156 bytes (31612 left)

The problem is that eth1 clashes with the LAN interface:

lan_ifnames=eth1 eth2

So what happens is that you get an instance of udhcpc wrongly running on eth1:

root@OpenWrt:/# ps auxwww |grep dhcp
  603 root        376 S   udhcpc -i eth1 -r -b -p /var/run/ -R
 1209 root        292 S   grep dhcp

and this in turn seems to mess up external IP comms. For example, if you add a default route and nameserver then do "ipkg update", it slows down then stalls completely after about 30K of data has been transferred. But unsetting the wan_proto/wan_ifname values, commit and reboot, and everything works just fine.

I can't tell *exactly* why having this udhcpc running on eth1 is causing this partial loss of comms, but clearly it shouldn't be there anyway.

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by mbm

  • Milestone set to 1.0-rc6
  • Resolution set to fixed
  • Status changed from new to closed

The S05nvram startup script will create defaults for some variables, set wan_proto=none and ignore the wan settings.

comment:2 Changed 10 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Is this actually a "wontfix" resolution? Or if a change has been made, can you give the SVN revision number?

Unfortunately the response given is ambiguous, I can parse it in two different ways:

(1) "Fixed. The S05nvram startup script will now create defaults for some variables, and set wan_proto=none and ignore the wan settings on the WL-HDD. See SVN xxxx"

(2) "The S05 nvram startup script creates defaults for some variables. Please just set wan_proto=none yourself and ignore the wan settings"

If it's case (1), I can't find any code for this in SVN.

If it's case (2) then the wiki needs updating to warn uses of the WL-HDD that this change needs to be applied by hand after installing OpenWRT. Also, for clarity please change the resolution from "fixed" to "wontfix".

comment:3 Changed 10 years ago by nico

  • Resolution set to worksforme
  • Status changed from reopened to closed

The 05nvram startup script does not set wan_proto=none, but wan_ifname=none only if it's not already set. The networking scripts will check later that ifnames are valid. The problem you were experiencing was caused by invalid wan_* settings that were not set by the 05nvram startup script itself.

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.