Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#5878 closed defect (worksforme)

Error decompressing mtd-utils package mtd-20090505.tar.gz during compilation.

Reported by: Gorby Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:


This happening all the time no matter of "make menuconfig" settings. Decompression of all previous packages runs smoothly.

System Ubuntu 8.10 on VMWare Workstation 6.5.3-185404.

Got image from here:

make[4]: Leaving directory `/home/iam/trunk/build_dir/host/squashfs4.0/squashfs-tools'
touch /home/iam/trunk/build_dir/host/squashfs4.0/.built
make[3]: Leaving directory `/home/iam/trunk/tools/squashfs4'
make[3]: Entering directory `/home/iam/trunk/tools/squashfs4'
install -m0755 /home/iam/trunk/build_dir/host/squashfs4.0/squashfs-tools/mksquashfs /home/iam/trunk/staging_dir/host/bin/mksquashfs4
install -m0755 /home/iam/trunk/build_dir/host/squashfs4.0/squashfs-tools/unsquashfs /home/iam/trunk/staging_dir/host/bin/unsquashfs4
mkdir -p /home/iam/trunk/staging_dir/host/stamp
touch /home/iam/trunk/staging_dir/host/stamp/.squashfs4_installed
make[3]: Leaving directory `/home/iam/trunk/tools/squashfs4'
make[3]: Entering directory `/home/iam/trunk/tools/mtd-utils'
mkdir -p /home/iam/trunk/dl
--2009-09-21 22:50:25--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1904640 (1.8M) [application/x-tar]
Saving to: `STDOUT'

100%[======================================>] 1,904,640   6.48M/s   in 0.3s    

2009-09-21 22:50:26 (6.48 MB/s) - `-' saved [1904640/1904640]

gzip -dc /home/iam/trunk/dl/mtd-20090505.tar.gz | /bin/tar -C /home/iam/trunk/build_dir/host/mtd-20090505/.. -xf - 

gzip: /home/iam/trunk/dl/mtd-20090505.tar.gz: not in gzip format
/bin/tar: This does not look like a tar archive
/bin/tar: Error exit delayed from previous errors
make[3]: *** [/home/iam/trunk/build_dir/host/mtd-20090505/.prepared6214eb5b7aeee081ae90b9e5e19472bc] Error 2
make[3]: Leaving directory `/home/iam/trunk/tools/mtd-utils'
make[2]: *** [tools/mtd-utils/compile] Error 2
make[2]: Leaving directory `/home/iam/trunk'
make[1]: *** [/home/iam/trunk/staging_dir/target-mips_uClibc-] Error 2
make[1]: Leaving directory `/home/iam/trunk'
make: *** [world] Ошибка 2

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by Gorby

Workaround (?): I used a mtd-utils.tar.gz from ticket #4340 to avoid this error.

comment:2 Changed 7 years ago by Gorby

This happening on every guest OS i instaled: Ubuntu 8.10, 9.04, Kubuntu 7.10, even self-compiled Gentoo 2008... Wierd thing! I just don't know what to do, because workaround solves issue with mtd-utils only, but compliling stops on another broken (?) package.

comment:3 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce that bug, please make sure that your VM is in a sane state.

comment:4 Changed 7 years ago by Gorby

This issue happened only with my old Pentium M 2GHz notebook, latest (or near so) VMWare tools (Workstation, Player, Server) and ANY *nix OS i installed. And with Core2Duo T5300 notebook - all ran smoothly even with the same virtual machine. So this seem like a VMWare optimization bug. Ticket closed.

comment:5 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.