Modify

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#6023 closed enhancement (fixed)

GIT - the stupid content tracker

Reported by: dmr-wrt@… Owned by: cshore
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Kamikaze 8.09
Keywords: git rcs kernel Cc:

Description

The revision control system heavily used by the Linux kernel team - just in case someone wants a gitshell in his Linux router.

Attachments (2)

git-1.6.5-kamikaze.tgz (960 bytes) - added by dmr-wrt@… 8 years ago.
Makefile (1.8 KB) - added by dmr-wrt@… 8 years ago.
Bare makefile

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by dmr-wrt@…

Changed 8 years ago by dmr-wrt@…

Bare makefile

comment:1 follow-up: Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Applied in r18555, thanks!

comment:2 in reply to: ↑ 1 Changed 8 years ago by thomas@…

Replying to florian:

Applied in r18555, thanks!

Doesn't build here for ar71xx:

libgit.a(path.o): In function `git_mkstemps':
path.c:(.text+0xad4): undefined reference to `mkstemps'
collect2: ld returned 1 exit status

I tried to add NO_MKSTEMPS="YesPlease" to the Makefile to make it compile, but that didn't help right now. I am trying to remove the build dir for git and see what happens then. I'll post again if I figured it out. Please reopen (it seems I am not permitted to reopen myself).

Thanks for adding git, it will allow me to push all my repositories to my flash drive via SSH.

comment:3 Changed 8 years ago by florian

I cannot reproduce that build issue on ar71xx, it builds fine for me here.

comment:4 Changed 8 years ago by thomas@…

Even after deleting my build_dir and staging_dir, the problem persists. This is my .config: http://dev.archlinux.org/~thomas/openwrt.config

comment:5 Changed 8 years ago by anonymous

Okay, it seems I screwed up before, adding NO_MKSTEMPS="YesPlease" to both the build and install commands fixes it. I don't know why I get the build failure and you don't.

However, it doesn't seem to useful to me, as the package is 4.2MB, maybe I can strip it down further or integrate it into the flash drive instead of the firmware image.

comment:6 Changed 7 years ago by cshore

  • Resolution fixed deleted
  • Status changed from closed to reopened

I can confirm this bug on brcm63xx

comment:7 Changed 7 years ago by cshore

  • Owner changed from developers to cshore
  • Status changed from reopened to accepted

comment:8 Changed 7 years ago by cshore

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed r21278

comment:9 Changed 7 years ago by nico

  • Milestone changed from Kamikaze to Backfire 10.03.1

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.