Modify

Opened 7 years ago

Closed 6 years ago

Last modified 2 years ago

#6139 closed defect (fixed)

hostapd fails to start when hwmode is set to 11a, 11b or 11bg

Reported by: js@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

Madwifi init script accepts and sets the correct hwmode in this format (11a, 11b or 11bg) when WPA/PSK encryption is not set. Hostapd requires hwmode to be set without '11' prefix.

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by openwrt@…

similar problem with r19254, wl500gPv1 atheros wifi.

I had to edit /lib/wifi/hostapd.sh to hardcode hwmode=a to get my wireless working. I use psk2 encryption. Without the change, the generated /var/run/hostapd-ath0.conf always contains hwmode=11a and hostapd doesn't start. Editing /etc/config/wireless doesn't work.

comment:2 Changed 6 years ago by Lukas Gruber <gruber@…>

still in r19932, 11g does not work, g does

comment:3 Changed 6 years ago by swalker

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r20363.

comment:4 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.