Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#6173 closed defect (worksforme)

Build from trunk failed, problem in zlib

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

The build failed on trunk downloaded by svn today.

CONFIG_TARGET_x86=y
CONFIG_TARGET_x86_generic_Alix=y

make[3]: Entering directory `/home/apeitz/download/openwrt/alix/trunk/package/zlib'
make -C /home/apeitz/download/openwrt/alix/trunk/build_dir/target-i386_uClibc-0.9.30.1/zlib-1.2.3 AR=i486-openwrt-linux-uclibc-ar AS="i486-openwrt-linux-uclibc-gcc -c -O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts" LD=i486-openwrt-linux-uclibc-ld NM=i486-openwrt-linux-uclibc-nm CC="i486-openwrt-linux-uclibc-gcc" GCC="i486-openwrt-linux-uclibc-gcc" CXX="i486-openwrt-linux-uclibc-g++" RANLIB=i486-openwrt-linux-uclibc-ranlib STRIP=i486-openwrt-linux-uclibc-strip OBJCOPY=i486-openwrt-linux-uclibc-objcopy OBJDUMP=i486-openwrt-linux-uclibc-objdump SIZE=i486-openwrt-linux-uclibc-size CFLAGS="-O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -fpic" libz.a libz.so
make[4]: Entering directory `/home/apeitz/download/openwrt/alix/trunk/build_dir/target-i386_uClibc-0.9.30.1/zlib-1.2.3'
make[4]: Nothing to be done for `libz.a'.
make[4]: * No rule to make target `libz.so'. Stop.
make[4]: Leaving directory `/home/apeitz/download/openwrt/alix/trunk/build_dir/target-i386_uClibc-0.9.30.1/zlib-1.2.3'
make[3]:
* home/apeitz/download/openwrt/alix/trunk/build_dir/target-i386_uClibc-0.9.30.1/zlib-1.2.3/.built Error 2
make[3]: Leaving directory `/home/apeitz/download/openwrt/alix/trunk/package/zlib'
make[2]: * [package/zlib/compile] Error 2
make[2]: Leaving directory `/home/apeitz/download/openwrt/alix/trunk'
make[1]:
* home/apeitz/download/openwrt/alix/trunk/staging_dir/target-i386_uClibc-0.9.30.1/stamp/.package_compile Error 2
make[1]: Leaving directory `/home/apeitz/download/openwrt/alix/trunk'
make: * [world] Fehler 2

Tested also on 8.09.1 and everything works perfect.

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by anonymous

Sorry, shame on me. I insert the wrong output:

i486-openwrt-linux-uclibc-ar rc libz.a adler32.o compress.o crc32.o gzio.o uncompr.o deflate.o trees.o zutil.o inflate.o infback.o inftrees.o inffast.o
i486-openwrt-linux-uclibc-gcc -lc -o libz.so.1.2.3 adler32.o compress.o crc32.o gzio.o uncompr.o deflate.o trees.o zutil.o inflate.o infback.o inftrees.o inffast.o
/home/apeitz/download/openwrt/alix/trunk/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib/gcc/i486-openwrt-linux-uclibc/4.1.2/../../../../i486-openwrt-linux-uclibc/lib/crt1.o: In function `_start':
(.text+0x18): undefined reference to `main'
collect2: ld returned 1 exit status
make[4]: *** [libz.so.1.2.3] Error 1
make[4]: Leaving directory `/home/apeitz/download/openwrt/alix/trunk/build_dir/target-i386_uClibc-0.9.30.1/zlib-1.2.3'
make[3]: *** [/home/apeitz/download/openwrt/alix/trunk/build_dir/target-i386_uClibc-0.9.30.1/zlib-1.2.3/.built] Error 2
make[3]: Leaving directory `/home/apeitz/download/openwrt/alix/trunk/package/zlib'
make[2]: *** [package/zlib/compile] Error 2
make[2]: Leaving directory `/home/apeitz/download/openwrt/alix/trunk'
make[1]: *** [/home/apeitz/download/openwrt/alix/trunk/staging_dir/target-i386_uClibc-0.9.30.1/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/apeitz/download/openwrt/alix/trunk'
make: *** [world] Fehler 2

comment:2 Changed 7 years ago by anonymous2

Changed tool chain to gcc-4.3.3+cs and the error dissappears

comment:3 Changed 7 years ago by ssatyavolu@…

I am hitting the same problem. The tool chain used is gcc-4.3.3+cs but still the same error occurs. Did you find a solution?

comment:4 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce that problem.

comment:5 Changed 7 years ago by florian

Fixed with r19012. I had not looked closely enough to the toolchain version you used.

comment:6 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.