Modify

Opened 8 years ago

Closed 7 years ago

Last modified 3 years ago

#6259 closed defect (fixed)

pppd 2.4.4 doesn't set default gateway

Reported by: aporter@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

When using pppd 2.4.4 in latest trunk, after the connection has been established pppd does not set the default gateway. ip route show or route -n will show no default GW set for the ppp0 device.

When I roll back to pppd 2.4.3 the GW is set. Since this is the only difference in my testing (2.4.4 vs 2.4.3) I'm going to attribute it to a defect in 2.4.4. Perhaps the defaultroute debian patch isn't effective on this version?

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by jow

Can you paste your network config please?

comment:2 Changed 7 years ago by aporter@…

Here you go:

config interface loopback
        option ifname lo
        option proto static
        option ipaddr 127.0.0.1
        option netmask 255.0.0.0

config interface lan
       option ifname eth0.2
       option type bridge
       option proto static
       option ipaddr 192.168.1.1
       option netmask 255.255.255.0

config interface wan
       option proto 3g
       option device /dev/ttyUSB0
       option service cdma

comment:3 Changed 7 years ago by aporter@…

I've also tried pppd 2.4.5 which resulted in the same issue.

With an ethernet WAN connection:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 eth0.1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
0.0.0.0         10.0.0.1        0.0.0.0         UG    0      0        0 eth0.1

With a PPP connection:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
66.174.208.64   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0

When there is no default GW set, applications such as StrongSwan start complaining.

comment:4 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

I believe this issue has been fixed with r22806.

comment:5 Changed 3 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.