Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#6308 closed defect (fixed)

trunk r18666, miniupnpd crashes when removing rules - solution inside

Reported by: thomas@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: miniupnpd, segfault, iptc_free Cc:

Description

There were some tickets about this, but all of them are closed.

When I add a port forward in miniupnpd, then delete it again, only the NAT rule is removed, the filter rule isn't. miniupnpd crashes then.

The problem is that 001-iptcrdr_memleaks.patch is invalid: The iptc_free is called inside delete_rule_and_commit already, leading to it being called twice. Thus, the iptc_free added by the patch causes a segfault.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

committed in r18667.

comment:2 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.