Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#6429 closed defect (duplicate)

Two Wifi cards not properly working

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,

I am using a routerstation pro with a bridge with eth0 and eth1.
I have installed two wifi cards inside :

  • R52N on fisrt slot and see as phy0
  • R2N on second slot and see as phy1

When I configured the first and second card, using same Channel, different SSID, same encryption (WPA2 Personnal/AES), both cards are working fine.
If I configure the second card using a different Channel, this card is not usable, and saw not as WPA2+AES but WEP.

Both cards are declared as type mac80211.

Here is non working configuration:

config 'wifi-device'  'radio0'
        option 'type'     'mac80211'
        option 'phy'    'phy0'
        option 'channel'  '10'
        option 'hwmode' '11ng'
        option 'disabled' '0'
        option 'diversity' '1'
        list 'ht_capab' 'HT40-'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'DSSS_CCK-40'

config 'wifi-iface'
        option 'device'   'radio0'
        option 'network'  'lan'
        option 'mode'     'ap'
        option 'ssid'     'ssid'
        option 'encryption' 'psk2+aes'
        option 'key'    'great_key'
        option 'hidden' '1'
        option 'bgscan' '0'
        option 'wds'    '0'

config wifi-device  'wifi1'
       option 'type'     'mac80211'
       option 'phy'    'phy1'
       option 'channel'  '4'
       option 'hwmode' '11ng'
       option 'disabled' '0'
       option 'diversity' '1'
       list 'ht_capab' 'HT40-'
       list 'ht_capab' 'SHORT-GI-40'
       list 'ht_capab' 'DSSS_CCK-40'

config wifi-iface
       option device   wifi1
       option network  lan
       option mode     ap
       option ssid     'another_ssid'
       option encryption psk2+aes
       option key      'great_key'
       option hidden   1
       option txpower  auto

Trunk version installed on my RouterStation Pro is r18909

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Cedric MARSOT <cmarsot@…>

Sorry, forgot to attach my email address.
I created another ticket. You can delete this one.

comment:2 Changed 7 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6430.

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.