Modify

Opened 7 years ago

Closed 6 years ago

#6719 closed defect (fixed)

WAN interface - unexpected initial DHCP request when configured to static IP

Reported by: lance@… Owned by: developers
Priority: response-needed Milestone: Backfire 10.03.1
Component: base system Version: Backfire 10.03 RC3
Keywords: IP static dhcp request boot Cc:

Description

I have noticed that when my WRT54GS v4 (running kamikaze 8.09, r14511) boots, even though it is configured to use a static IP on its WAN port (as set in /etc/config/network), it still requests an address from the DHCP server before going on to ignore this and use its configured static IP.

The DHCP request occurs some seconds after the initial UDP 192.168.1.255.4919 broadcast, just as the boot sequence is ending as shown in this tcpdump on the DHCP server:

17:46:07.940691 IP 192.168.1.1.2048 > 192.168.1.255.4919: UDP, length 1001
17:46:33.600832 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from xx:xx:xx:xx:xx:xx (oui Unknown), length 360
17:46:33.606402 IP 192.168.200.10.67 > 192.168.200.207.68: BOOTP/DHCP, Reply, length 300
17:46:33.608043 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from xx:xx:xx:xx:xx:xx (oui Unknown), length 368
17:46:33.613958 IP 192.168.200.10.67 > 192.168.200.207.68: BOOTP/DHCP, Reply, length 300
17:46:38.610048 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:39.610045 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:40.610046 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:41.610045 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:42.610044 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:43.610046 arp who-has 192.168.200.207 tell 192.168.200.10

If I set the interface to use a dynamic IP, the sequence is the same, but the first of the block of "who-has" requests gets a response:

17:56:08.480046 arp who-has 192.168.200.207 tell 192.168.200.10
17:56:08.480450 arp reply 192.168.200.207 is-at xx:xx:xx:xx:xx:xx (oui Unknown)

Should this be happening ?
After this the configuration goes on to work as expected.

Attachments (0)

Change History (9)

comment:1 in reply to: ↑ description Changed 7 years ago by thepeople

  • Milestone changed from Kamikaze to Backfire 10.03

Replying to lance@…:

I have noticed that when my WRT54GS v4 (running kamikaze 8.09, r14511) boots, even though it is configured to use a static IP on its WAN port (as set in /etc/config/network), it still requests an address from the DHCP server before going on to ignore this and use its configured static IP.

The DHCP request occurs some seconds after the initial UDP 192.168.1.255.4919 broadcast, just as the boot sequence is ending as shown in this tcpdump on the DHCP server:

17:46:07.940691 IP 192.168.1.1.2048 > 192.168.1.255.4919: UDP, length 1001
17:46:33.600832 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from xx:xx:xx:xx:xx:xx (oui Unknown), length 360
17:46:33.606402 IP 192.168.200.10.67 > 192.168.200.207.68: BOOTP/DHCP, Reply, length 300
17:46:33.608043 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from xx:xx:xx:xx:xx:xx (oui Unknown), length 368
17:46:33.613958 IP 192.168.200.10.67 > 192.168.200.207.68: BOOTP/DHCP, Reply, length 300
17:46:38.610048 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:39.610045 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:40.610046 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:41.610045 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:42.610044 arp who-has 192.168.200.207 tell 192.168.200.10
17:46:43.610046 arp who-has 192.168.200.207 tell 192.168.200.10

If I set the interface to use a dynamic IP, the sequence is the same, but the first of the block of "who-has" requests gets a response:

17:56:08.480046 arp who-has 192.168.200.207 tell 192.168.200.10
17:56:08.480450 arp reply 192.168.200.207 is-at xx:xx:xx:xx:xx:xx (oui Unknown)

Should this be happening ?
After this the configuration goes on to work as expected.

Can you please test this on trunk or 10.03 beta?

comment:2 Changed 7 years ago by andrea@…

Using 10.03 here, same router/model/version.
Flashed from the old Whiterussian gui with clear flag set.
Config for bridge and lan is untouched.

Added alias definition via gui:
config 'alias'

option 'proto' 'static'
option 'interface' 'wan'
option 'ipaddr' '192.168.2.1'
option 'netmask' '255.255.255.0'

Added pptp definition via gui:
config 'interface' 'wan'

option 'ifname' 'eth0.1'
option 'peerdns' '1'
option 'defaultroute' '1'
option 'proto' 'pptp'
option 'username' 'XXXXX'
option 'password' 'XXXXX'
option 'keepalive' '10'
option 'server' '192.168.2.2'

WAN interface comes up just fine and local clients can connect to the internet.
At reboot, dhcp queries from the router mac address are observed as described above. After pacifying the router with a dchp reply, the router behaves normally and static addresses for lan and alias appear as specified in config.

comment:3 Changed 7 years ago by andrea@…

Additional information: in my case, just waiting for the dhcp timeouts to expire without answering the queries from the router gets me nowhere. Also, without defining an alias for the wan port the pptp client cannot contact the pptp server although the dchp answer sent _to_ the router is used to configure eth0.1 (wan port, afaik)

comment:4 Changed 7 years ago by andrea@…

Tested again on 10.03-rc3: config'ed as shown above, eth0.1 briefly gets an IP during boot, then looses it.

comment:5 Changed 7 years ago by anonymous

could this be related to or caused by #7082?

comment:6 Changed 7 years ago by nico

  • Version changed from Kamikaze 8.09 to Backfire 10.03 RC3

comment:7 follow-up: Changed 6 years ago by nico

  • Priority changed from normal to response-needed

Can you confirm this issue is still present in 10.03.1-rc1 ?

comment:8 in reply to: ↑ 7 Changed 6 years ago by lance@…

Replying to nico:

Can you confirm this issue is still present in 10.03.1-rc1 ?

I'm now using a WRT54GL v1.1 (not sure if that is significant). Testing 10.03.1-rc1 on the WAN port with a dynamic IP shows normal DHCP interaction after the UDP 4919 broadcast. If the interface is set to a static IP on the correct subnet, nothing follows the UDP 4919 packet until later when other general network traffic starts to flow.
The problem appears to be resolved assuming that my change of hardware is not a factor.

comment:9 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.