Modify

Opened 6 years ago

Closed 4 years ago

Last modified 2 years ago

#6907 closed defect (invalid)

brcm47xx: b43 driver hangs Asus WL-500gP v2

Reported by: Adrian Byszuk <adebex@…> Owned by: hauke
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: b43, wifi, brcm47xx, asus Cc:

Description

Scanning for new networks or setting up router in AP mode (using defaults) hangs router. It looks like the OOMkiller *literally* kills all processes.
Happens on both 2.6.32.9 and 32.10.

I haven't tested 2.6.33 kernel yet.

I'm willing to help as much as possible with this problem (and b43 driver in general), so if you would like me to test new kernels/patches or different modes (WPA encryption, STA mode) just let me know.

I attach 3 logs from serial console (2 from scanning, 1 from setting AP mode). IMHO they are very similar, but maybe skilled developer will notice any difference.

Attachments (5)

05.log (27.2 KB) - added by Adrian Byszuk <adebex@…> 6 years ago.
After trying to scan wifi
21.03.2010 19.40.log (22.0 KB) - added by Adrian Byszuk <adebex@…> 6 years ago.
After trying to scan wifi
21.03.2010 20.00.log (31.4 KB) - added by Adrian Byszuk <adebex@…> 6 years ago.
After /sbin/wifi using defaults
r20737.log (208.9 KB) - added by microcris 6 years ago.
r20960.log (89.6 KB) - added by microcris 6 years ago.
build 20960 log

Download all attachments as: .zip

Change History (57)

Changed 6 years ago by Adrian Byszuk <adebex@…>

After trying to scan wifi

Changed 6 years ago by Adrian Byszuk <adebex@…>

After trying to scan wifi

Changed 6 years ago by Adrian Byszuk <adebex@…>

After /sbin/wifi using defaults

comment:1 Changed 6 years ago by thepeople

  • Owner changed from developers to nbd
  • Status changed from new to assigned

comment:2 Changed 6 years ago by thepeople

  • Owner changed from nbd to mb

comment:3 Changed 6 years ago by thepeople

  • Milestone changed from Kamikaze to Backfire 10.03

comment:4 Changed 6 years ago by thepeople

  • Owner changed from mb to hauke

comment:5 Changed 6 years ago by anup.vasudev@…

Hi,
Any luck on fixing this? Or any workaround?

Changed 6 years ago by microcris

comment:6 Changed 6 years ago by microcris

The file r20737.log is a log of build 20737 after enable wireless and reboot the router

comment:7 Changed 6 years ago by Chris Martin <chris@…>

I have just logged ticket #7117 - I am getting the same error on a WL500Pv2, but not on wrt54gs v1.1 - So it is probably related to the new LP-PHY support in the b43 driver

comment:8 Changed 6 years ago by Chris Martin <chris@…>

I have just tested with kernel 2.6.33.2 - I get the same issue

comment:9 Changed 6 years ago by celejar@…

Just wanted to report that I'm apparently seeing the same problem (with Blackfire) on an Asus 520gu, which I believe has the same hardware as the WL-500gP v2 (Broadcom 5354 radio). I don't have serial access to the box, so I can't provide much in the way of useful information. dmesg and other details here:

http://lists.infradead.org/pipermail/b43-dev/2010-April/000064.html

comment:10 Changed 6 years ago by anonymous

Im just another user with a dead WL500Pv2

Changed 6 years ago by microcris

build 20960 log

comment:11 Changed 6 years ago by microcris

The file r20960.log is a log of build 20960 after enable wireless and reboot the router.
I hope this time it has the debug information needed

comment:12 Changed 6 years ago by hauke

As Larry sad in http://lists.infradead.org/pipermail/b43-dev/2010-April/000067.html there seam to be a memory leak somewhere. Please look at the memory usage before loading b43 and before trying to associating with an access point.

comment:13 Changed 6 years ago by microcris

I can do that but all what was described happens right after enable the wireless module, there is no chance to associate with an ap.

comment:14 Changed 6 years ago by microcris

I can only see the available memory with the wireless module disabled… I don’t know if there is any use in doing that.
By the log, the out of memory also occurs here

"Out of memory: kill process 281 (rcS) score 43 or a child"

But like I said, it happens right after enable the wireless module.

comment:15 Changed 6 years ago by jbemmel@…

Getting similar results on my Asus WL-520GU. dmesg output:
cfg80211: Calling CRDA to update world regulatory domain
b43-phy0: Broadcom 5354 WLAN found (core revision 13)
phy0: Selected rate control algorithm 'minstrel'
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
cfg80211: World regulatory domain updated:

(start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
(2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
(2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
(2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
(5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
(5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

b43 ssb0:3: firmware: requesting b43/ucode13.fw
b43 ssb0:3: firmware: requesting b43/lp0initvals13.fw
b43 ssb0:3: firmware: requesting b43/lp0bsinitvals13.fw
b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)
b43-phy0 ERROR: PHY init: Channel switch to default failed
b43-phy0 ERROR: Microcode not responding
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Driversb43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)
b43-phy0 ERROR: PHY init: Channel switch to default failed

comment:16 Changed 6 years ago by jbemmel@…

Someone did manage to get b43 work with the Broadcom 5354:
http://www.mail-archive.com/bcm43xx-dev@lists.berlios.de/msg08788.html

They did the following:

try this:
in phy_common.c (next-to-last line), in b43_phyop_switch_analog_generic,
comment out b43_write16(dev, B43_MMIO_PHY0, on ? 0 : 0xF4);

There is also a reference to this logic to be implemented for that function:
http://bcm-v4.sipsolutions.net/802.11/PHY/Anacore

comment:17 Changed 6 years ago by jbemmel@…

Am happy to report that wireless is now working on my Asus WL-520GU (Broadcom 5354).
It needs the B43_STABLE setting ( firmware 4.150.10.5 )

I also took the latest snapshot of the b43 wireless drivers, not sure if that helped.

comment:18 Changed 6 years ago by anup.vasudev@…

Could you explain the B43_STABLE setting please? Where and how do i do that setting? Sorry, am a newbie.

comment:19 follow-up: Changed 6 years ago by jbemmel@…

It's in the generated .config file after you do 'make menuconfig', it's called "CONFIG_B43_STABLE" (you can use 'grep B43 .config' to find it). You can also set it via the GUI: Kernel modules -> Wireless Drivers -> kmod-b43 -> Configuration -> b43 firmware version (stable)

It may be that it is set by default, in which case you don't have to worry.
FYI - I also tweaked 'CONFIG_B43_FW_SQUASH_COREREVS="13"'

comment:20 in reply to: ↑ 19 Changed 6 years ago by anup.vasudev@…

Replying to jbemmel@…:

It's in the generated .config file after you do 'make menuconfig', it's called "CONFIG_B43_STABLE" (you can use 'grep B43 .config' to find it). You can also set it via the GUI: Kernel modules -> Wireless Drivers -> kmod-b43 -> Configuration -> b43 firmware version (stable)

It may be that it is set by default, in which case you don't have to worry.
FYI - I also tweaked 'CONFIG_B43_FW_SQUASH_COREREVS="13"'

Oh ok, thanks.I dont have a setup to build backfire yet. I was hoping it was a setting to do after installing the backfire firmware. Anyways, thanks!

comment:21 follow-up: Changed 6 years ago by ldolse

I can confirm that building with the stable B43 kernel module in the configuration utility also works with the Asus WL500gpV2.

comment:22 in reply to: ↑ 21 Changed 6 years ago by anup.vasudev@…

Replying to ldolse:

I can confirm that building with the stable B43 kernel module in the configuration utility also works with the Asus WL500gpV2.

Hi, i just built backfire with the stable B43 module. It still dosent work :( The only improvement i see is that the device dosent get stuck anymore. wifi tries to start and then goes down. But i can still access the router. Am using Asus WL500gpV2. Built on backfire branch. dmesg result...
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
device wlan0 left promiscuous mode
br-lan: port 2(wlan0) entering disabled state
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state

comment:23 follow-up: Changed 6 years ago by hauke

Please verify if the problem was "fixed" with the new firmware or with the new version of compat-wireless.

Just build recent trunk with experimental firmware.

comment:24 Changed 6 years ago by hauke

The spec at http://bcm-v4.sipsolutions.net/802.11/PHY/Anacore is implemented as descriped for phy_lp

comment:25 in reply to: ↑ 23 Changed 6 years ago by linchen <linchen987@…>

Replying to hauke:

Please verify if the problem was "fixed" with the new firmware or with the new version of compat-wireless.

Just build recent trunk with experimental firmware.

I just build r21446 with the experimental firmware,still have the problem on 520GU.
wifi can work with stable firmware only in ap mode, when i change it into sta mode ,get error:
root@OpenWrt:/# /etc/init.d/network restart
Read error: Network is down, reopening socket
udhcpc: sendto: Network is down
Read error: Network is down, reopening socket
Error for wireless request "Set Power Management" (8B2C) :

SET failed on device wlan0 ; Operation not supported.

comment:26 Changed 6 years ago by zooloz

I just built the latest trunk (r21449), using the experimental B43 firmware for my wl520gu and if you load it in monitor mode (as opposed to AP or STA), it does work for a while receiving packets. After a couple of hours, dmesg output is:
b43-phy0 ERROR: MAC suspend failed
b43-phy0 ERROR: MAC suspend failed
b43-phy0 ERROR: MAC suspend failed
b43-phy0 ERROR: MAC suspend failed
etc.
The packet counter from ifconfig also seems to stop in that the wireless doesn't receive any more packets.

I am not sure how/if this helps, but thought I'd throw it out there.

comment:27 Changed 6 years ago by hauke

  • Resolution set to fixed
  • Status changed from assigned to closed

No the stable firmware is the default one again.

This was changed in r21470

comment:28 Changed 6 years ago by anup.vasudev@…

when will the changed implementation of the phy_lp be dropped on to backfire branch?

comment:29 Changed 6 years ago by Gorkhaan

Waiting for a patch or something. I'm getting the same bug.

comment:30 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

This still dosent work with the latest build from trunk.

comment:31 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

this ticket seems to be talking about various different issues. if you still have issues with trunk, please make a ticket with some useful information about it.

comment:32 Changed 6 years ago by metamatt

I tried 10.03 and 10.03.1-rc1 on a brand new WL520GU. After bringing wifi up, 10.03 didn't work (I couldn't ssh into the router, I could ping it, but ping times bounced between 1ms and 1300ms); 10.03.1-rc1 seems to be working fine, so it looks like this fix will be in 10.03.1 and not just trunk builds?

comment:33 Changed 5 years ago by trinque@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This crash also occurs on the ASUS wl520gu. After a few hours the wifi locks up completely, and anything using the interface hangs indefinitely. Ethernet still works.

comment:34 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

This should have been solved with RC5.

comment:35 Changed 5 years ago by dumghen

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm still getting this error on RC5 version backfire. (same router)

b43-phy0 ERROR: MAC suspend failed
b43-phy0 ERROR: MAC suspend failed
b43-phy0 ERROR: MAC suspend failed
b43-phy0 ERROR: MAC suspend failed
b43-phy0 ERROR: MAC suspend failed

As a result, wireless hangs

comment:36 Changed 5 years ago by anonymous

Hi, are any workarounds for ASUS WL-520gu with trunk or 10.3.01-rc5? I had to use dd-wrt yet..

comment:37 Changed 5 years ago by dumghen

Could not see dmesg log lines, Couldn't ssh anymore to the router.

Happened on RC6 and on trunk. 20.Nov.2011

comment:38 Changed 5 years ago by hauke

Trunk r29485 now contains firmware version 666.2 from driver 5.100.138. Could someone please build trunk with this wireless firmware and report the results with one of the affected devices.

I tried to get an ASUS WL500GPv2, ASUS WL-520GU or dlink dir-320, but they currently cost over 25 Euro and I am not willing to invest that for such an old device.

comment:39 Changed 5 years ago by anonymous

I have tried binaries 10.03, 10.03.1-rc5 and 10.03.1-rc6 for ASUS WL-520GU. Both 10.03 and 10.03.1-rc6 cause the router to hang once the wifi is turned on (both wireless and wire are not available any more).
10.03.1-rc5 seems to work fine.

comment:40 Changed 5 years ago by Chris Martin <chris@…>

I just built from trunk r29576 and selected 666.2 firmware
loaded it on asus wl500gpv2. The router still hangs when the radio is enabled.
I don't have a console on this unit any longer, however I will get one in the next couple of days. I will let you know latter what errors I get.

comment:41 follow-up: Changed 4 years ago by anonymous

I've suceeded with wifi on Asus Wl-500gP v2. I compiled backfire 10.03.1(r29597) and selected b43 driver and in its configuration "Firmware 410.2160 from driver 4.150.10.5(stable)" in menuconfig. With these settings wifi works fine.

comment:42 in reply to: ↑ 41 Changed 4 years ago by anonymous2

Hi, I also observed the same problems when the throughput is very high and QoS is enabled. I use r28694 and I will try trunk soon. Does someone know what are the differences between all the B43 firmwares? Currently i use 410.2160 from driver 4.150.10.5 (2007-05-26 15:32:10). After reboot, as long as QoS is disabled, everything seems to be working ok and the "MAC SUSPEND FAILED" didn't appear yet.

comment:43 Changed 4 years ago by anonymous

Hi, I have tested all firmwares and only 410.2160(4.150.10.5) works with Asus Wl-500gP v2. Other drivers hang router and it is impossible to log into it. It happens in current trunk. With 410.2160 driver wifi works fine, however MAC SUSPEND FAILED appeared once in 4 days and did not hang the router. I have QoS enabled.

comment:44 Changed 4 years ago by hauke

This is a known bug and I am currently working on it with my Asus wl-500gu.
See: http://comments.gmane.org/gmane.linux.drivers.bcm54xx.devel/13097

comment:45 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from reopened to closed

This was fixed in r30665.

It was tested with an Asus WL-520GU and should also work for the WL-500gP v2. Could someone please test the other devices like the D-Link Dir-320 and report back when the problem still exists or the wifi led is not on when wifi is on. Such a report should also contain the complete nvram removed by some keys or other private data.
If I do not hear any negative reports I will merge this into backfire soon.

comment:46 Changed 4 years ago by Enrico Gueli <enrico.gueli@…>

It works for me (Asus WL-520GU). Thanks Hauke for all your effort!

comment:47 Changed 4 years ago by r2d2

Can confirm it's fine with trunk snapshot on 500gP V2 in modes sta/wpa2 and ap/no enc.

Appreciate youre work.

comment:48 Changed 4 years ago by BijilBaji

Please guys could any of you explain the steps in little bit more detail i am using asus 520gu..

comment:49 Changed 4 years ago by vavmar@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi, from fresh firmware "openwrt-brcm47xx-squashfs.trx" RC6 I've tried follow this

http://wiki.openwrt.org/doc/recipes/routedclient#using.masquerade

tutorial and setup only simple Masqerade, to be able only connect to wifi.
My HW is WL-500g Deluxe. Thanks for help.

I ended with this:

root@OpenWrt:~# ifup wan
Received SIGTERM
Entering released state
Read error: Network is down, reopening socket
Error for wireless request "Set Power Management" (8B2C) :

SET failed on device wlan0 ; Operation not supported.

udhcpc: sendto: Network is down
Read error: Network is down, reopening socket
udhcpc (v1.15.3) started
Received SIGTERM
Entering released state
root@OpenWrt:~# udhcpc (v1.15.3) started
Sending discover...
Sending discover...
Sending discover...
Sending discover...
Sending discover...
Sending discover...

comment:50 Changed 4 years ago by hauke

  • Resolution set to invalid
  • Status changed from reopened to closed

Please use the form or irc for support requests or open a new ticket with more a more detailed description what you have done, this is unrelated to the original issue.

comment:51 Changed 4 years ago by richlv@…

probably resolution should be set to "fixed", as the original problem was fixed ?

comment:52 Changed 2 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.