Modify

Opened 7 years ago

Closed 5 years ago

Last modified 3 years ago

#6954 closed defect (worksforme)

cyassl fails to compile - patch failed after r20459

Reported by: Elphidium Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I think this has something with r20459, cause r20459 is empty.

log:

Applying ./patches/100-makefile_dollar_make.patch using plaintext:
patching file Makefile.am
patching file Makefile.in

Applying ./patches/110-makefile_disable_examples_tests.patch using plaintext:
patching file Makefile.am
patching file Makefile.in
patching file ctaocrypt/Makefile.am
patching file ctaocrypt/Makefile.in

Applying ./patches/120-makefile_destdir.patch using plaintext:
(Stripping trailing CRs from patch.)
patching file Makefile.am
Hunk #1 FAILED at 8.
1 out of 1 hunk FAILED -- saving rejects to file Makefile.am.rej
patching file Makefile.in
Patch failed!  Please fix ./patches/120-makefile_destdir.patch!
gmake[3]: *** [/home/elphidium/320/26/trunk/build_dir/target-mipsel_uClibc-0.9.30.1/cyassl-1.4.0/.prepared_dde37a1f6594633392770cb0a968499a] Error 1
gmake[3]: Leaving directory `/home/elphidium/320/26/trunk/package/cyassl'
gmake[2]: *** [package/cyassl/compile] Error 2
gmake[2]: Leaving directory `/home/elphidium/320/26/trunk'
gmake[1]: *** [/home/elphidium/320/26/trunk/staging_dir/target-mipsel_uClibc-0.9.30.1/stamp/.package_compile] Error 2
gmake[1]: Leaving directory `/home/elphidium/320/26/trunk'
gmake: *** [world] Error 2

Attachments (0)

Change History (16)

comment:1 follow-up: Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

comment:2 in reply to: ↑ 1 Changed 7 years ago by telstar924@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to florian:

I have the same problem, (x86 platform)

Applying ./patches/100-makefile_dollar_make.patch using plaintext:
patching file Makefile.am
patching file Makefile.in

Applying ./patches/110-makefile_disable_examples_tests.patch using plaintext:
patching file Makefile.am
patching file Makefile.in
patching file ctaocrypt/Makefile.am
patching file ctaocrypt/Makefile.in

Applying ./patches/120-makefile_destdir.patch using plaintext:
(Stripping trailing CRs from patch.)
patching file Makefile.am
Hunk #1 FAILED at 8.
1 out of 1 hunk FAILED -- saving rejects to file Makefile.am.rej
patching file Makefile.in
Patch failed! Please fix ./patches/120-makefile_destdir.patch!
make[3]: * mnt/storage1/vassilis/trunk/build_dir/target-i386_uClibc-0.9.30.3/cyassl-1.4.0/.prepared_6b349f8517306d0ca8a3ab5231282488 Error 1
make[3]: Leaving directory `/mnt/storage1/vassilis/trunk/package/cyassl'
make[2]:
* [package/cyassl/compile] Error 2
make[2]: Leaving directory `/mnt/storage1/vassilis/trunk'
make[1]: * mnt/storage1/vassilis/trunk/staging_dir/target-i386_uClibc-0.9.30.3/stamp/.package_compile Error 2
make[1]: Leaving directory `/mnt/storage1/vassilis/trunk'
make:
* [world] Error 2

Is there something to be done in order to fix this patch ?

TIA for any assistance

comment:3 follow-up: Changed 7 years ago by jow

I cannot reproduce it either. Please make sure that your workcopy is up-to-date and that the cyassl patch directory is clean.

comment:4 in reply to: ↑ 3 Changed 7 years ago by telstar924@…

Replying to jow:

I cannot reproduce it either. Please make sure that your workcopy is up-to-date and that the cyassl patch directory is clean.

I tried to rebuild everything. I deleted all the directories , I followed the instructions from the wiki, i downloaded through svn ,etc... I selected the x86 platform with the minimum configuration.

The patch fails again

Applying ./patches/100-makefile_dollar_make.patch using plaintext:
patching file Makefile.am
patching file Makefile.in

Applying ./patches/110-makefile_disable_examples_tests.patch using plaintext:
patching file Makefile.am
patching file Makefile.in
patching file ctaocrypt/Makefile.am
patching file ctaocrypt/Makefile.in

Applying ./patches/120-makefile_destdir.patch using plaintext:
(Stripping trailing CRs from patch.)
patching file Makefile.am
Hunk #1 FAILED at 8.
1 out of 1 hunk FAILED -- saving rejects to file Makefile.am.rej
patching file Makefile.in
Patch failed! Please fix ./patches/120-makefile_destdir.patch!
make[3]: * mnt/storage1/vassilis/trunk/build_dir/target-i386_uClibc-0.9.30.1/cyassl-1.4.0/.prepared_6b349f8517306d0ca8a3ab5231282488 Error 1
make[3]: Leaving directory `/mnt/storage1/vassilis/trunk/package/cyassl'
make[2]:
* [package/cyassl/compile] Error 2
make[2]: Leaving directory `/mnt/storage1/vassilis/trunk'
make[1]: * mnt/storage1/vassilis/trunk/staging_dir/target-i386_uClibc-0.9.30.1/stamp/.package_compile Error 2
make[1]: Leaving directory `/mnt/storage1/vassilis/trunk'
make:
* [world] Error 2

Any tip ?

TIA for any assistance

comment:5 Changed 7 years ago by Elphidium

I was using slackware 13.0 and was having the issue, tryed almost everything but not a update to slackware-current, changed to ubuntu 10.04 beta1 and it works again.

comment:6 follow-up: Changed 7 years ago by thepeople

Sounds like whatever slackware is using for patch is broken, can you provide what version of patch it is using, maybe some more info about your slackware install.

comment:7 in reply to: ↑ 6 Changed 7 years ago by telstar924@…

Replying to thepeople:

Sounds like whatever slackware is using for patch is broken, can you provide what version of patch it is using, maybe some more info about your slackware install.

I use Slackware 13/current , the patch version is 2.54 , i replaced this with the latest stable gnu patch (ver 2.61) . It seems that the problem has disappeared.
Thank you for your tip thepeople

comment:8 Changed 7 years ago by thepeople

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:9 Changed 7 years ago by mik30@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have exactly the same problem.
I use CentOS 4.8
Updating patch from 2.54 to 2.61 does not help.

comment:10 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

Should be fixed by r21187

comment:11 Changed 7 years ago by mik30@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

The hint in r21187 does not fix the problem either.
I removed the \r with tr -d "\r" as well as with dos2unix commands.
I still get the exact same error.

comment:12 Changed 7 years ago by jow

Don't strip all \r" that is wrong. Only the "\r" in the first hunk header. The file to patch *is in dos format* if you convert the patch to unix format *it will not fit*

comment:13 Changed 7 years ago by mik30@…

The 1st hunk header

--- a/Makefile.am
+++ b/Makefile.am
@@ -8,14 +8,11 @@ basic:

does not contain any(!) "\r" = 0x13.

So which "\r" = 0x13 do you exactly mean?
Be as precisely as you can. I would prefer
if you could post the fileoffset of the
0x13 bytes to remove.

In addition to that I do not think that you are right in your
assumption that the patch file does not work if it is in unix
file format (without 0x13). The 130-x patch file in the same
directory is completely unix file format.

comment:14 Changed 7 years ago by jow

The 130 patch does not touch Makefile.am - the *.am file is the only one in DOS format as it seems. Also r21187 removed the "\r" I am talking about.

Anyway, I could not reproduce the issue in the first place but found some open issues where "patch" incorrectly does "\r" stripping if one of the hunk headers has "\r" included which might happen if the unified diff was generated using the "--show-function-line" option, this has been the case and I removed the stray char it.

As long as you see "(Stripping trailing CRs from patch.)" your version of "patch" does something it is not supposed to do. Further Google searches revealed that LC_ALL might affect the behavior of patch as well.

I tested with patch 2.5.9 on Ubuntu/Debian and cannot verify the issue, with or without stray "\r":

$ patch -p1 < patches/120-makefile_destdir.patch 
patching file Makefile.am
patching file Makefile.in

comment:15 Changed 5 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:16 Changed 3 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.