Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7030 closed defect (fixed)

bcm47xx: b43 problems at power on, fixable later

Reported by: noz Owned by: acinonyx
Priority: normal Milestone: Backfire 10.03.1
Component: base system Version: Backfire 10.03 RC2
Keywords: Cc:

Description

WRTSL54GS, just upgraded to Backfire-RC2

At startup, I think during /etc/init.d/network (though possibly during hotplug coldplugging), when the WiFi is brought up for the first time, there are repeated errors of the form:

b43 ssb1:0: firmware: requesting b43/ucode5.fw
b43 ssb1:0: firmware: requesting b43-open/ucode5.fw
b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users
/Drivers/b43#devicefirmware and download the correct firmware for
this driver version. Please carefully read all instructions on this
website.

This is accompanied by long pauses, presumably one per command that accesses the WiFi interface.

However, once boot has finally completed (~10-15 minutes!) if you execute /etc/init.d/network restart, then the firmware is loaded entirely correctly, and wlan0 comes up as desired.

Attachments (0)

Change History (7)

comment:1 Changed 7 years ago by noz

<xMff> you should use option network wifi in /etc/config/wireless instead and leave ifname blank in /etc/config/network

This does indeed fix it, but we either need to a) stop that option causing the delay, or b) stop putting that option in when LuCi configures a wireless interface.

comment:2 Changed 7 years ago by thepeople

  • Owner changed from developers to jow
  • Status changed from new to assigned

comment:3 Changed 7 years ago by jow

  • Resolution set to wontfix
  • Status changed from assigned to closed

LuCI does not put that ifname in there if you configure wireless neither is it there by default. The handling of wifi ifaces in the gui will change in the future but not in time for 10.03.

comment:4 Changed 7 years ago by noz

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Sorry, but I don't think we can just brush this away with a "wontfix". Removing ifname from /etc/config/network breaks a huge load of other things, such as firewall setup, dnsmasq, and probably others as well.

We probably need to tackle the root cause.

comment:5 Changed 7 years ago by acinonyx

  • Owner changed from jow to acinonyx
  • Status changed from reopened to accepted

comment:6 Changed 7 years ago by acinonyx

  • Resolution set to fixed
  • Status changed from accepted to closed

Should be fixed together with #6958 in r20684. If not, please re-open.

Thanks for reporting!

comment:7 Changed 7 years ago by nico

  • Milestone changed from Backfire 10.03 to Backfire 10.03.1

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.