Modify

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#7081 closed defect (fixed)

x86 will not boot on Soekris net4511: Can't find root-device

Reported by: OpenWRT@… Owned by: acoul
Priority: normal Milestone: Backfire 10.03.1
Component: kernel Version: Backfire 10.03 RC3
Keywords: Cc:

Description (last modified by thepeople)

The unit starts booting, spouting kernel-messages, then freezes:

Linux version 2.6.32.10 (openwrt@wrt1.marcant.net) (gcc version 4.1.2) #7 Fri A0KERNEL supported cpus:
  Intel GenuineIntel
  AMD AuthenticAMD
  NSC Geode by NSC
  Cyrix CyrixInstead
  Centaur CentaurHauls
  Transmeta GenuineTMx86
  Transmeta TransmetaCPU
  UMC UMC UMC UMC
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000004000000 (usable)
 BIOS-e820: 00000000fff00000 - 0000000100000000 (reserved)
DMI not present or invalid.
last_pfn = 0x4000 max_arch_pfn = 0x100000
init_memory_mapping: 0000000000000000-0000000004000000
ACPI Error: A valid RSDP was not found (20090903/tbxfroot-219)
64MB LOWMEM available.
  mapped low ram: 0 - 04000000
  low ram: 0 - 04000000
  node 0 low ram: 00000000 - 04000000
  node 0 bootmap 00001000 - 00001800
(6 early reservations) ==> bootmem [0000000000 - 0004000000]
  #0 [0000000000 - 0000001000]   BIOS data page ==> [0000000000 - 0000001000]
  #1 [0001000000 - 00013481c0]    TEXT DATA BSS ==> [0001000000 - 00013481c0]
  #2 [000009fc00 - 0000100000]    BIOS reserved ==> [000009fc00 - 0000100000]
  #3 [0001349000 - 000134f000]              BRK ==> [0001349000 - 000134f000]
  #4 [0000007000 - 0000011000]          PGTABLE ==> [0000007000 - 0000011000]
  #5 [0000001000 - 0000002000]          BOOTMAP ==> [0000001000 - 0000002000]
Zone PFN ranges:
  DMA      0x00000000 -> 0x00001000
  Normal   0x00001000 -> 0x00004000
Movable zone start PFN for each node
early_node_map[2] active PFN ranges
    0: 0x00000000 -> 0x0000009f
    0: 0x00000100 -> 0x00004000
Using APIC driver default
No local APIC present or hardware disabled
APIC: disable apic facility
Allocating PCI resources starting at 4000000 (gap: 4000000:fbf00000)
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16159
Kernel command line: root=/dev/hda2 rootfstype=ext2 rootwait console=tty0 consosPID hash table entries: 256 (order: -2, 1024 bytes)
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Initializing CPU#0
Memory: 61132k/65536k available (2190k kernel code, 3992k reserved, 749k data, )virtual kernel memory layout:
    fixmap  : 0xfffa3000 - 0xfffff000   ( 368 kB)
    vmalloc : 0xc4800000 - 0xfffa1000   ( 951 MB)
    lowmem  : 0xc0000000 - 0xc4000000   (  64 MB)
      .init : 0xc12e0000 - 0xc1329000   ( 292 kB)
      .data : 0xc1223a79 - 0xc12df020   ( 749 kB)
      .text : 0xc1000000 - 0xc1223a79   (2190 kB)
Checking if this processor honours the WP bit even in supervisor mode...Ok.
SLUB: Genslabs=13, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Hierarchical RCU implementation.
NR_IRQS:288
Console: colour dummy device 80x25
console [tty0] enabled
console [ttyS0] enabled
Calibrating delay loop... 49.76 BogoMIPS (lpj=248832)
Mount-cache hash table entries: 512
CPU: AMD 486 DX/4-WB stepping 04
Checking 'hlt' instruction... OK.
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.01 entry at 0xf7861, last bus=1
PCI: Using configuration type 1 for base access
bio: create slab <bio-0> at 0
ACPI: Interpreter disabled.
SCSI subsystem initialized
PCI: Probing PCI hardware
pci 0000:00:09.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:09.0: PME# disabled
pci 0000:00:12.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:12.0: PME# disabled
pci 0000:00:13.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:13.0: PME# disabled
Switching to clocksource pit
pnp: PnP ACPI: disabled
pci 0000:00:13.0: BAR 6: address space collision on of device [0x3f000000-0x3f0]pci 0000:00:09.0: CardBus bridge, secondary bus 0000:01
pci 0000:00:09.0:   IO window: 0x001000-0x0010ff
pci 0000:00:09.0:   IO window: 0x001400-0x0014ff
pci 0000:00:09.0:   PREFETCH window: 0x4000000-0x7ffffff
pci 0000:00:09.0:   MEM window: 0x8000000-0xbffffff
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
NET: Registered protocol family 1
platform rtc_cmos: registered platform RTC device (no PNP device found)
scx200: NatSemi SCx200 Driver
microcode: no support for this CPU vendor
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 119
io scheduler noop registered
io scheduler deadline registered (default)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12b
Non-volatile memory driver v1.3
Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
PNP: No PS/2 controller found. Probing ports directly.
i8042.c: Can't read CTR while initializing i8042.
i8042: probe of i8042 failed with error -5
mice: PS/2 mouse device common for all mice
cpuidle: using governor ladder
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
Using IPI Shortcut mode
Waiting for root device /dev/sda2...

Replacing sda2 with hda2 (as this was the usual name for the root-device) gave the same results: Waiting for root sevice.
Looks like the CF-card wasn't detected so the root-fs cannot be mounted.

Attachments (0)

Change History (9)

comment:1 Changed 7 years ago by thepeople

  • Description modified (diff)

comment:2 Changed 7 years ago by fercerpav@…

I think it's worth trying

IDE_GENERIC=y
IDE_GD=y
IDE_GD_ATA=y

Please attach here another dmesg with these options enabled.

comment:3 Changed 7 years ago by acoul

  • Owner changed from developers to acoul
  • Status changed from new to accepted

comment:4 Changed 7 years ago by blah@…

I did the IDE_GENERIC=y option but same problem. I have a working voyage linux install now would post dmesg but posting is deied with error saying i am a spammer.

comment:5 Changed 7 years ago by fercerpav@…

You can attach files here :)

BTW, it would be nice if you provided also a non-working dmesg with all the three options i mentioned enabled, i really suspect (seen in some dmesg on the web) that it's the good old method of "ide generic" used on your board.

comment:6 Changed 7 years ago by acoul

the problem has been confirmed, I will get back on this ASAP

comment:7 Changed 7 years ago by acoul

  • Resolution set to fixed
  • Status changed from accepted to closed

fixed on trunk r20757 & backfire r20758 (thanks for reporting)

comment:8 Changed 7 years ago by rmcgonegal@…

I had a very similar problem trying to boot my own build of backfire on an Alix x86 board.
The boot would hang at the same place as above but with a
Waiting for root device /dev/mtdblock0 ...

The problem turned out to be in the menuconfig item Target Images / Root partition on target device.

On previous builds such as 8.09.2 I had set this to /dev/hda2 and had no problems (not sure if it actually used this parameter though). On backfire I had to set this to /dev/sda2 and it works.

comment:9 Changed 6 years ago by Jepplogue

dobry poczatek

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.