Modify

Opened 7 years ago

Last modified 3 years ago

#7090 reopened defect

wifi leds not working on DIR-825 (ath9k)

Reported by: anonymous Owned by: juhosg
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

The wifi leds are not working on the Dlink DIR-825, rev. B2 (and apparently B1 as well) with the ath9k driver, neither "automagically" nor manually from /sys/class/leds/ath9k-phy...

Attachments (2)

led.patch (4.0 KB) - added by anonymous 7 years ago.
DIR-825 Wi-Fi LEDs fix
dir-825.wifi.leds.patch (1.8 KB) - added by rand256 7 years ago.
DIR-825 Wi-Fi LEDs fix new

Download all attachments as: .zip

Change History (39)

comment:1 Changed 7 years ago by glenno@…

Confirming B1 also has no wifi LED's under 9.03 or 10.03. They work fine under stock Dlink firmware!

comment:2 Changed 7 years ago by Athan

Confirming this bug. None of the radio LEDs work under 10.03

comment:3 Changed 7 years ago by MortAGU

Confirmed! This bug still exists in latest trunk.

comment:4 Changed 7 years ago by anonymous

Confirming bug in 10.03 on B2 hardware.

comment:5 Changed 7 years ago by anonymous

Still unfixed, so annoying!

comment:6 Changed 7 years ago by anonymous

You guyz are great , i heart fully appreciate your work
Any idea when the WIFI LED bug will get fixed?
i am using latest backfire trunk.

comment:7 Changed 7 years ago by anonymous

just as info, leds work fine on dd-wrt :)

comment:8 Changed 7 years ago by anonymous

bump

comment:9 Changed 7 years ago by anonymous

DIR-825 uses the same GPIO LED PIN as WNDR3700 does. That is number 5. So there should me made additional patch for /driver/net/wireless/ath/ath9k/gpio.c

Take a look at the /backfire/package/mac80211/patches/410-ath9k-wndr3700-led-pin-fix.patch and please make the same for DIR-825.

Thanks in advance. Leonid Protasov

comment:10 Changed 7 years ago by jow

  • Owner changed from developers to juhosg
  • Status changed from new to assigned

Changed 7 years ago by anonymous

DIR-825 Wi-Fi LEDs fix

comment:11 Changed 7 years ago by anonymous

I've attached the patch made by Leonid Protasov (posted here), but with fixed formatting and which, therefore, can be can be correctly applied into current trunk.

comment:12 Changed 7 years ago by anonymous

Addition to the last comment:

With the patch above Wi-Fi LEDs now can be lit, and trigger phyXradio at ath9k-phyX::radio LED works ok for now.
However, flashing of these LEDs at data transfers via ath9k-phyX::tx, ath9k-phyX::rx and ath9k-phyX::assoc with corresponding triggers still does not work.

comment:13 Changed 7 years ago by rand256

Ok, after changeset r23822 the patch above isn't working anymore.
I'm attaching a new one.

Changed 7 years ago by rand256

DIR-825 Wi-Fi LEDs fix new

comment:14 Changed 7 years ago by yatakama

Can you please provide a patching order for these, or a changeset for which to run them against? It seems your patch references 411-ath9k-dir825-led-pin-fix.patch but I only managed to patch the backfire branch by creating the 411-ath9k-dir825-led-pin-fix.patch using the previous patch in this ticket, then running your patch with patch -p0 < dir-825.wifi.leds.patch, moving 411-ath9k-dir825-led-pin-fix.patch out of the patches/ directory and running it too, ignoring the already applied patches. Backfire then compiled, but the leds still don't work. I also tried applying to trunk but it doesn't work there, as several files referenced in the patch are missing.
Thanks for your help.

comment:15 Changed 7 years ago by anonymous

File 411-ath9k-dir825-led-pin-fix.patch from the first patch should not be used in latest trunk. If you already applied previous patch, then you need to remove 411-ath9k-dir825-led-pin-fix.patch file and revert source changes using svn revert command. Then apply only the new patch and rebuild the firmware.

As for backfire - I suppose the first patch should be used there until changeset r23822 will be merged into backfire. But I didn't tested whether it works.

comment:16 Changed 7 years ago by yatakama

Thanks, it didn't work against trunk, but I managed to apply it to backfire r23593. The wireless leds finally light up.

comment:17 Changed 7 years ago by ziesemer

Neither path appears to apply cleanly to the current backfire branch, e.g. r24168.

Can someone please supply an updated patch, or commit to the branch?

comment:18 Changed 7 years ago by ziesemer

I applied the latest patch (dir-825.wifi.leds.patch) manually against backfire branch r24168, and even tried manually adding the "config 'led'" entries to /etc/config/system and rebooted, but the LEDs still don't light. (I even set one of them to be on by default.)

comment:19 Changed 7 years ago by ziesemer

It looks like there was significant work done on this within the past day on changeset r24159.

If this is working, can it please be merged into the backfire branch?

comment:20 Changed 7 years ago by anonymous

a long time ago, LEDs still don't light.

now, LEDs still don't light.

please fix it.

comment:21 Changed 7 years ago by ziesemer

Just tried trunk (r24191), and didn't observe any improvement. Rolling back to the backfire branch for now, and promise to stop flooding this ticket until someone else has another update.

comment:22 Changed 7 years ago by rand256

Just compiled and flashed current trunk r24191 with applied dir-825.wifi.leds.patch, and I can admit that finally everything here works as expected.

Now there are only two ath9k LED devices present at /sys/class/leds: ath9k-phy0 and ath9k-phy1, others are removed. And these two has new default trigger value of phy0tpt and phy1tpt accordingly. This trigger automatically lit radio LEDs when Wi-Fi is up, and make them blink as bytes pass through Wi-Fi interface. No need to change anything in /etc/config/system, all works with default values.

comment:23 follow-up: Changed 7 years ago by anonymous

When will this patch be officially applied?

comment:24 follow-up: Changed 7 years ago by anonymous

installed build from trunk, 11.12.2010 - leds not working, even in fresh install or set up according with previous message (phy0tpt, phy1tpt as triggers)

comment:25 in reply to: ↑ 24 Changed 7 years ago by anonymous

Replying to anonymous:

installed build from trunk, 11.12.2010 - leds not working, even in fresh install or set up according with previous message (phy0tpt, phy1tpt as triggers)

Because you need to manually apply the patch above for them to work.

comment:26 in reply to: ↑ 23 Changed 7 years ago by bartp

Replying to anonymous:

When will this patch be officially applied?

seems like never

comment:27 follow-up: Changed 7 years ago by magyarsz

Fixed in trunk. Pls close the ticket.

comment:28 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:29 in reply to: ↑ 27 ; follow-up: Changed 7 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to magyarsz:

Fixed in trunk. Pls close the ticket.

In latest RC4 works only 5GHz LED. 2.4GHz remains black even if led config is written.

comment:30 in reply to: ↑ 29 ; follow-up: Changed 7 years ago by anonymous

Replying to anonymous:

Replying to magyarsz:

Fixed in trunk. Pls close the ticket.

In latest RC4 works only 5GHz LED. 2.4GHz remains black even if led config is written.

Obviously that's because RC4 is not a trunk.

comment:31 in reply to: ↑ 30 ; follow-up: Changed 7 years ago by anonymous

Replying to anonymous:

Replying to anonymous:

Replying to magyarsz:

Fixed in trunk. Pls close the ticket.

In latest RC4 works only 5GHz LED. 2.4GHz remains black even if led config is written.

Obviously that's because RC4 is not a trunk.

The mac80211 backported to the backfire branch. And this led problem is mac80211 related and not openwrt.

comment:32 in reply to: ↑ 31 Changed 7 years ago by anonymous

Replying to anonymous:

The mac80211 backported to the backfire branch. And this led problem is mac80211 related and not openwrt.

To fix led problem /target/linux/ar71xx files should be modified, not mac80211. See changesets r24649 and r24650.

comment:33 Changed 7 years ago by juhosg

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in Backfire (r24925) as well.

comment:34 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

works only 5GHz LED. 2.4GHz remains black even if led config is written.

comment:35 Changed 6 years ago by anonymous

trunk r27153 works only 5GHz LED. 2.4GHz remains black even if led config is written.

comment:36 Changed 3 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

comment:37 Changed 3 years ago by jogo

  • Version changed from Backfire 10.03 RC3 to Trunk

Is this still an issue in Barrier Braker RC3 or trunk?

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.