Modify

Opened 6 years ago

Closed 6 years ago

#7131 closed defect (duplicate)

WARNING: at net/sched/sch_generic.c:261 0x801fc32c()

Reported by: nikolay@… Owned by: juhosg
Priority: normal Milestone: Backfire 10.03.1
Component: other Version: Backfire 10.03 Beta
Keywords: Cc:

Description

Network stop working with:


WARNING: at net/sched/sch_generic.c:261 0x801fc32c()

NETDEV WATCHDOG: eth1 (ag71xx): transmit queue 0 timed out

Modules linked in: nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k ath9k_common ath9k_hw ath mac80211 crc_ccitt cfg80211 compat_firmware_class compat arc4 aes_generic deflate ecb cbc leds_gpio button_hotplug gpio_buttons input_polldev input_core

Call Trace:[<800683c4>] 0x800683c4

[<800683c4>] 0x800683c4

[<8007cb6c>] 0x8007cb6c

[<801fc32c>] 0x801fc32c

[<8007cbec>] 0x8007cbec

[<801e79f4>] 0x801e79f4

[<801fc32c>] 0x801fc32c

[<80263450>] 0x80263450

[<80261dc8>] 0x80261dc8

[<81440398>] 0x81440398

[<80263478>] 0x80263478

[<801fc1c8>] 0x801fc1c8

[<80087250>] 0x80087250

[<800709f0>] 0x800709f0

[<8008238c>] 0x8008238c

[<81ff8000>] 0x81ff8000

[<81ff8000>] 0x81ff8000

[<8008246c>] 0x8008246c

[<8006082c>] 0x8006082c

[<80060a00>] 0x80060a00

[<81ff8000>] 0x81ff8000

[<8006b330>] 0x8006b330

[<8006c7d0>] 0x8006c7d0

[<80060a20>] 0x80060a20

[<802d1a48>] 0x802d1a48

[<802d13a8>] 0x802d13a8

[<81ff8000>] 0x81ff8000

[<81ff8000>] 0x81ff8000

[<81ff8000>] 0x81ff8000

---[ end trace bfb6bd76c29e91af ]---

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by anonymous

TL-WR741ND

comment:2 in reply to: ↑ description Changed 6 years ago by sKAApGIF

I can confirm this error. Eth1 (the wan port) will get a dhcp lease and work only for approx 5mins. After that it's just a matter of time before this output is produced. I compiled the kernel with symbol table:

WARNING: at net/sched/sch_generic.c:261 dev_watchdog+0x164/0x260()
NETDEV WATCHDOG: eth1 (ag71xx): transmit queue 0 timed out
Modules linked in: nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k ath9k_common ath9k_hw ath mac80211 crc_ccitt cfg80211 compat_firmware_class compat arc4 aes_generic deflate ecb cbc leds_gpio button_hotplug gpio_buttons input_polldev input_core
Call Trace:
[<8006837c>] dump_stack+0x8/0x34
[<8007ce88>] warn_slowpath_common+0x70/0xb0
[<8007cf08>] warn_slowpath_fmt+0x24/0x30
[<801f7b80>] dev_watchdog+0x164/0x260
[<8008756c>] run_timer_softirq+0x14c/0x1d8
[<800826a8>] do_softirq+0xb0/0x148
[<80082788>] do_softirq+0x48/0x6c
[<8006082c>] ret_from_irq+0x0/0x4
[<80060a20>] r4k_wait+0x20/0x40
[<8006c840>] cpu_idle+0x24/0x44
[<802e1a48>] start_kernel+0x33c/0x354

comment:3 in reply to: ↑ description Changed 6 years ago by anonymous

apologies for the bad formatting, let my try again:

------------[ cut here ]------------
WARNING: at net/sched/sch_generic.c:261 dev_watchdog+0x164/0x260()
NETDEV WATCHDOG: eth1 (ag71xx): transmit queue 0 timed out
Modules linked in: nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k ath9k_common ath9k_hw ath mac80211 crc_ccitt cfg80211 compat_firmware_class compat arc4 aes_generic deflate ecb cbc leds_gpio button_hotplug gpio_buttons input_polldev input_core
Call Trace:
[<8006837c>] dump_stack+0x8/0x34
[<8007ce88>] warn_slowpath_common+0x70/0xb0
[<8007cf08>] warn_slowpath_fmt+0x24/0x30
[<801f7b80>] dev_watchdog+0x164/0x260
[<8008756c>] run_timer_softirq+0x14c/0x1d8
[<800826a8>] __do_softirq+0xb0/0x148
[<80082788>] do_softirq+0x48/0x6c
[<8006082c>] ret_from_irq+0x0/0x4
[<80060a20>] r4k_wait+0x20/0x40
[<8006c840>] cpu_idle+0x24/0x44
[<802e1a48>] start_kernel+0x33c/0x354

---[ end trace 1076957814cec527 ]---

comment:4 Changed 6 years ago by koolcho@…

This problem can be fixed by setting MTU to 1400 on wan port:

vi /etc/config/network

in the "config interface wan" add 	
option mtu	1400

I've found this solution from http://wiki.openwrt.org/toh/tp-link/tl-wr941nd and it worked perfectly for me.

comment:5 Changed 6 years ago by thepeople

  • Owner changed from developers to juhosg
  • Status changed from new to assigned

comment:6 Changed 6 years ago by Pieter "Fate" Hollants <pieter@…>

And this seems to be the same as #6754.

comment:7 Changed 6 years ago by nbd

  • Resolution set to duplicate
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.