Modify

Opened 7 years ago

Closed 7 years ago

#7218 closed defect (fixed)

bind9/named can't find pif-file when stoppin/restarting

Reported by: Sami Olmari <jaarli@…> Owned by: jow
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03
Keywords: bind, bind9, named, init, init.d Cc:

Description

x86 Backfire stable, when bind9 is used, the /etc/init.d/named daemon says it can't find pidfile when stopping the service, thus it doesn't stop.

I looked into the named script and saw it configuring and using pidfile to be /var/run/named.pid, but for some reason the pid-file still gets to be generated at /var/run/named/named.pid. This is why it can't be stopped.

Attachments (1)

named.diff (186 bytes) - added by sami@… 7 years ago.
/etc/init.d/named corrected diff

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to assigned

comment:2 Changed 7 years ago by jow

  • Resolution set to obsolete
  • Status changed from assigned to closed

Already fixed in r20379 and duplicate of #6903

comment:3 Changed 7 years ago by Quentin Armitage <quentin@…>

  • Resolution obsolete deleted
  • Status changed from closed to reopened

No, the problem is the other way round. r20379 changed the pid file specified in the init script from /var/run/named/named.pid to /var/run/named.pid. The problem is that bind uses /var/run/named/named.pid, and so r20379 created the problem, and that change needs reverting.

I have already patched my local copy of the package to change it back to /var/run/named/named.pid, following inspection of the bind code to confirm what it uses as its pidfile, and that then makes /etc/init.d/named stop to work.

comment:4 Changed 7 years ago by Quentin Armitage <quentin@…>

Ah, my closing comment, with typo, was completely ambiguous. What I meant was, the change to specify the pid file as /var/run/named/named.pid made the command "/etc/init.d/named stop" start working.

Apologies for any confusion caused.

Changed 7 years ago by sami@…

/etc/init.d/named corrected diff

comment:5 Changed 7 years ago by sami@…

I attached diff to correct /etc/init.d/named to look pid-file from correct location

comment:6 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

Committed in r22215 - thanks.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.