Modify

Opened 7 years ago

Closed 7 years ago

Last modified 13 months ago

#7635 closed defect (fixed)

quilt-0.47.tar.gz error on the OpenSUSE 11.3 32bit

Reported by: sniperpr@… Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: toolchain Version: Backfire 10.03
Keywords: error quilt Cc:

Description

gzip -dc /home/soltek/openwrt/backfire/dl/quilt-0.47.tar.gz | /bin/tar -C /home/soltek/openwrt/backfire/build_dir/host/quilt-0.47/.. -xf - 
ls: cannot access ./patches: No such file or directory
touch /home/soltek/openwrt/backfire/build_dir/host/quilt-0.47/.preparedb26bc450d9059c8f6590c991266fcf4f
(cd /home/soltek/openwrt/backfire/build_dir/host/quilt-0.47/; if [ -x configure ]; then cp -fpR /home/soltek/openwrt/backfire/scripts/config.{guess,sub} /home/soltek/openwrt/backfire/build_dir/host/quilt-0.47// &&  ./configure CFLAGS="-O2 -I/home/soltek/openwrt/backfire/staging_dir/host/include" CPPFLAGS="-O2 -I/home/soltek/openwrt/backfire/staging_dir/host/include" LDFLAGS="-L/home/soltek/openwrt/backfire/staging_dir/host/lib" SHELL="/bin/bash" --target=i586-suse-linux --host=i586-suse-linux --build=i586-suse-linux --program-prefix="" --program-suffix="" --prefix=/home/soltek/openwrt/backfire/staging_dir/host --exec-prefix=/home/soltek/openwrt/backfire/staging_dir/host --sysconfdir=/home/soltek/openwrt/backfire/staging_dir/host/etc --localstatedir=/home/soltek/openwrt/backfire/staging_dir/host/var ; fi )
checking for i586-suse-linux-gcc... no
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ANSI C header files... yes
checking for fchmod... yes
checking for chmod... yes
checking for mkstemp... yes
checking for mkdir... yes
checking for rmdir... yes
checking for strchr... yes
checking for strrchr... yes
checking for strerror... yes
checking for an ANSI C-conforming const... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking whether lstat dereferences a symlink specified with a trailing slash... yes
checking whether stat accepts an empty string... no
checking for a BSD-compatible install... /usr/bin/install -c
checking whether #! works in shell scripts... yes
checking for bash... /bin/bash
checking whether /bin/bash quoting works... yes
checking for gcp... no
checking for cp... /home/soltek/openwrt/backfire/staging_dir/host/bin/cp
checking whether /home/soltek/openwrt/backfire/staging_dir/host/bin/cp -l works... yes
checking for gdate... no
checking for date... /bin/date
checking whether /bin/date --rfc-822 works... yes
checking for perl... /usr/bin/perl
checking for grep... (cached) /usr/bin/grep
checking whether /usr/bin/grep -q works... yes
checking whether /usr/bin/grep understands (foo|bar)... yes
checking for tail... /usr/bin/tail
checking whether /usr/bin/tail -n works... yes
checking for tr... /usr/bin/tr
checking whether /usr/bin/tr understands a-z ... yes
checking for sed... /home/soltek/openwrt/backfire/staging_dir/host/bin/sed
checking whether /home/soltek/openwrt/backfire/staging_dir/host/bin/sed understands (foo|bar)... yes
checking for gawk... /usr/bin/gawk
checking whether /usr/bin/gawk supports sub... yes
checking for pod2man... /usr/bin/pod2man
checking for column... /usr/bin/column
checking for getopt... /usr/bin/getopt
checking for getopt --long syntax... yes
checking for mktemp... /bin/mktemp
checking whether /bin/mktemp -d works... yes
checking for diff... /usr/bin/diff
checking for patch... /usr/bin/patch
checking the version of /usr/bin/diff... 2.8.7-cvs
checking the version of /usr/bin/patch... patch
configure: error:
quilt requires at least version 2.4 of GNU patch. You can download a
current version of patch from ftp.gnu.org, or if you already have GNU patch
then you can supply its path with the '--with-patch=' option.

make[3]: *** [/home/soltek/openwrt/backfire/build_dir/host/quilt-0.47/.configured] Error 1
make[3]: Leaving directory `/home/soltek/openwrt/backfire/tools/quilt'
make[2]: *** [tools/quilt/compile] Error 2
make[2]: Leaving directory `/home/soltek/openwrt/backfire'
make[1]: *** [/home/soltek/openwrt/backfire/staging_dir/target-arm_v5t_uClibc-0.9.30.3_eabi/stamp/.tools_install_nnyny] Error 2
make[1]: Leaving directory `/home/soltek/openwrt/backfire'
make: *** [world] 错误 2
patch --version
GNU patch 2.6.1.81-5b68
Copyright (C) 2003, 2009, 2010 Free Software Foundation, Inc.
Copyright (C) 1988 Larry Wall

License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Larry Wall and Paul Eggert
$quilt --version
0.48

Attachments (1)

7635-quilt_patch-version.diff (1.1 KB) - added by Pieter "Fate" Hollants 7 years ago.
Patch to fix quilt's configure script to work with newer patch versions

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by sniperpr@…

Resolved!

download ftp://ftp.gnu.org/gnu/patch/patch-2.6.tar.bz2
./configure
make
make install

is OK.

The problem is that OpenSUSE 11.3.

please close it.

comment:2 Changed 7 years ago by acoul

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 7 years ago by Pieter "Fate" Hollants

  • Resolution invalid deleted
  • Status changed from closed to reopened

Wrong resolution. You've downloaded patch 2.6, while openSUSE uses patch 2.6.1.81, which has a modified --version syntax:

# patch --version
GNU patch 2.6.1.81-5b68

And quilt's configure.ac does this:

set -- `$PATCH --version 2> /dev/null`
patch_version=$2

which breaks, because $1 reads "GNU", $2 now reads "patch" and $3 is the version number.

Attached patch fixes quilt's configure script for future patch versions.

Changed 7 years ago by Pieter "Fate" Hollants

Patch to fix quilt's configure script to work with newer patch versions

comment:4 Changed 7 years ago by acoul

  • Resolution set to fixed
  • Status changed from reopened to closed

applied in r22397. this patch is best to be directed upstream. thank you.

comment:5 Changed 7 years ago by Pieter "Fate" Hollants <pieter@…>

Actually I just discovered someone else sent a patch to the upstream mailing list:
http://lists.nongnu.org/archive/html/quilt-dev/2010-06/msg00002.html

You might want to pick up that patch instead, no idea when it will eventually get merged into a new quilt release.

comment:6 Changed 13 months ago by anonymous

Thank you !!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.