Opened 6 years ago

Closed 6 years ago

#7830 closed defect (fixed)

[incl. fix] Default /etc/config/network breaks LuCI's Administration->Network->Switch page on ar71xx

Reported by: anonymous Owned by: jow
Priority: normal Milestone: Backfire 10.03.1
Component: luci Version: Backfire 10.03.1 RC2
Keywords: Cc:


On my WR1043ND the default /etc/config/network makes LuCI's Administration - Network - Switch page does not show VLAN<->Port assignments.

Changing the switch configuration in /etc/config/network from

config 'switch'
    option 'name' 'rtl8366rb'

to include the devicename

config 'switch' 'rtl8366rb'
    option 'name' 'rtl8366rb'

fixes it so it looks like this:

The CPU port is still not displayed properly because there is no way to configure tagged ports in luci.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

I'l rework the switch page.

comment:2 Changed 6 years ago by anonymous

This also happens on DIR-825 with RTL8366S switch using Backfire 10.03.1 RC3.

comment:3 Changed 6 years ago by nico

  • Component changed from base system to luci

comment:4 Changed 6 years ago by anonymous

still valid info in recent Backfire builds.

config 'switch' 'rtl8366rb'

comment:5 Changed 6 years ago by jow

It should be fixed in LuCI trunk, I'll switch to it soon in backfire.

comment:6 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Switch config has been reworked in LuCI 0.10

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.