Modify

Opened 6 years ago

Closed 6 years ago

#7918 closed defect (wontfix)

[backfire][orion] Wireless client bridge not working on WRT350Nv2

Reported by: maddes Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: kernel Version: Backfire 10.03.1 RC2
Keywords: backfire orion wrt350nv2 bridge ath9k Cc:

Description

Wireless client bridge is not working on LinkSys WRT350N v2.0 (Orion). Also tested in 11g-only mode.
Same Backfire revision works on a WRT54G v2.2.
Looks like a target or platform-related issue (ath9k).
Both routers were setup via luci interface.


Builds tested on WRT350Nv2 and not working:

  • Backfire 10.03.1 post-rc3 r22998 (Linux 2.6.32.16)


Builds tested on WRT54G v2.2 and working:

  • Backfire 10.03.1 post-rc3 r22998 (Linux 2.6.32.16)


Setup procedure on both routers:

  1. Go to luci menu "Network" => "Wifi"
  2. Check "Enable"
  3. Enter correct "Network Name (ESSID)"
  4. Set "Mode" to "Join (Client)"
  5. Set "Encryption" to "WPA2-PSK"
  6. Enter correct "Key"

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

Client bridge is not supported on any non-Broadcom driver. On Broadcom it only works because of some driver-internal Layer 2 NAT hacks.
I'm working on an alternative solution that has similar transparency as client bridge, but works on Layer 3. The code is at git://nbd.name/relayd.git but it is not integrated yet.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.