Modify

Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#8138 closed enhancement (fixed)

[patch] Kismet not finding/linking libnl-tiny to support vap creation on mac80211

Reported by: framer99 Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: kismet kismet_server libnl libnl-tiny mac80211 nl80211 Cc:

Description

A previous ticket for a different issue also exposed this "missing libnl" configure issue with Kismet.
https://dev.openwrt.org/ticket/6962

That ticket was closed as obsolete when the OP fixed his issue, but the libnl/configure issue still exists.

With a normally working mac80211 type wireless device, trying to use Kismet is(was) frustrating:

ERROR: Source 'wlan0' doesn't have mac80211 support, disabling VAP
       creation of default monitor mode VAP

If you are using the mac80211 driver and the iw command is working, you'd assume kismet would work since it supports VAP creation on mac80211 drivers. You can manually create the monitor interface with iw and launch kismet on that, but why not have it automatic.

The problem is that Kismet server uses netlink to perform the VAP creation and therefore cannot not fully support mac80211 drivers without libnl(or libnl-tiny).

The configure script output notes this at configure time, but does not error out, just builds without mac80211 support.

The attached patch gets kismet-server to use libnl-tiny in place of libnl.

Attachments (2)

kismet_server_libnl-tiny.patch (443 bytes) - added by framer99 6 years ago.
help kismet_server use libnl-tiny
kismet_server_libnl-tiny.2.patch (443 bytes) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by framer99

help kismet_server use libnl-tiny

comment:1 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Committed in r23678 - thanks!

Changed 5 years ago by anonymous

comment:2 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.