Opened 10 years ago

Closed 10 years ago

#821 closed defect (duplicate)

buildroot-ng strace doesn't follow forks, as of r4902

Reported by: seniorr@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:


When executing:

strace -f -o /tmp/strace.log /usr/bin/foo

I find that strace.log does not show forked processes.

In the case of:

strace -ff -o /tmp/strace.log /usr/bin/foo

I find /tmp/strace.log and /tmp/strace.log.<pid>, but /tmp/strace.log.<pid> is empty. It looks like strace isn't attaching to the forked process or something.

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #668

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.