Modify

Opened 6 years ago

Closed 5 years ago

Last modified 2 years ago

#8251 closed defect (duplicate)

Cann't connect to WiFi with brcm47xx/broadcom-wl

Reported by: srarix <starix@…> Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Cann't connect to WiFi AP. Router reqest password, but return error on checking it. Switching encryption to 'none' cann't solve problem. Buld with default parammetrs.

Target: trunk r24004
Platform: brcm47xx with Broadcom proprietary drivers
Device: ASUS wl500gpv2
Client: Netbook Samsun NC10 with Windows 7

Running process:
/usr/sbin/nas -P /var/run/nas.wl0.pid -H 34954 -i wl0 -A -m 128 -w 4 -s OpenWrt -g 3600 -F -k pa$$w0rd

Wireless config:

config 'wifi-device' 'wl0'
        option 'type' 'broadcom'
        option 'channel' '6'
        option 'disabled' '0'
        option 'hwmode' '11bg'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'OpenWrt'
        option 'encryption' 'psk2'
        option 'key' 'pa$$w0rd'

lsmod:

wl                   1480560  0
switch_robo             3952  0
switch_core             5136  1 switch_robo
diag                    7488  0

Attachments (1)

dmesg.txt (6.6 KB) - added by srarix <starix@…> 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by srarix <starix@…>

comment:1 Changed 6 years ago by srarix <starix@…>

root@router:~# wifi down
root@router:~# wifi up
wl0: Invalid argument
wl0: Invalid argument
root@router:~#

comment:2 Changed 6 years ago by Chris Martin <chris@…>

This message a duplicate of ticket:7954

I have done a bit of debugging on this and I have added my comments to the original ticket

comment:3 Changed 6 years ago by jow

  • Milestone changed from Backfire 10.03.1 to Attitude Adjustment (trunk)

we do not support brcm47xx + wl in backfire

comment:4 Changed 5 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

comment:5 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.