Modify

Opened 5 years ago

Closed 4 years ago

Last modified 22 months ago

#8380 closed defect (fixed)

x86 platform -> libcurl compilation error

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description (last modified by hauke)

I try to compile libcurl and i get these errors

'''configure: WARNING: This libcurl built is probably not ABI compatible with previous
configure: WARNING: builds! You MUST read lib/README.curl_off_t to figure it out.'''
checking for long long... no
checking for ssize_t... no
checking for bool... no
checking for windows.h... (cached) no
checking for winsock2.h... (cached) no
checking for ws2tcpip.h... (cached) no
checking for sys/types.h... (cached) yes
checking for sys/socket.h... (cached) no
'''checking for curl_socklen_t data type... unknown
configure: error: cannot find data type for curl_socklen_t.'''
make[3]: *** [/mnt/storage1/vassilis/trunk/build_dir/target-i386_uClibc-0.9.31/curl-7.21.2/.configured_] Error 1
make[3]: Leaving directory `/mnt/storage1/vassilis/trunk/feeds/packages/libs/curl'
make[2]: *** [package/feeds/packages/curl/compile] Error 2
make[2]: Leaving directory `/mnt/storage1/vassilis/trunk'
make[1]: *** [/mnt/storage1/vassilis/trunk/staging_dir/target-i386_uClibc-0.9.31/stamp/.package_compile] Error 2
make[1]: Leaving directory `/mnt/storage1/vassilis/trunk'
make: *** [world] Error 2}}}

Attachments (3)

config.log (493.6 KB) - added by anonymous 5 years ago.
curl config.log r24509
100-cross_compile.patch (4.4 KB) - added by anonymous 5 years ago.
100-cross_compile.2.patch (4.7 KB) - added by Marcos Tadeu <marcos@…> 4 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 5 years ago by hauke

  • Description modified (diff)

comment:2 Changed 5 years ago by anonymous

Yes,I have the same problem.

comment:3 Changed 5 years ago by anonymous

me too on ar71xx.

comment:4 Changed 5 years ago by anonymous

m also having the same problem, i m unable to compile libcurl :(

comment:5 Changed 5 years ago by acoul

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in latest trunk. issue a "make distclean" before testing.

comment:6 Changed 5 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

in r24479 the problem is still exist.

checking for curl_socklen_t data type... unknown
configure: error: cannot find data type for curl_socklen_t.

comment:7 Changed 5 years ago by jow

Please attach config.log

Changed 5 years ago by anonymous

curl config.log r24509

comment:8 Changed 5 years ago by anonymous

ixp4xx same problem too

configure: WARNING: This libcurl built is probably not ABI compatible with previous
configure: WARNING: builds! You MUST read lib/README.curl_off_t to figure it out.
checking for long long... no
checking for ssize_t... no
checking for bool... no
checking for windows.h... (cached) no
checking for winsock2.h... (cached) no
checking for ws2tcpip.h... (cached) no
checking for sys/types.h... (cached) yes
checking for sys/socket.h... (cached) no
checking for curl_socklen_t data type... unknown
configure: error: cannot find data type for curl_socklen_t.
make[3]: * openwrt/10.03/build_dir/target-armeb_v5te_uClibc-0.9.30.1_eabi/curl-7.21.2/.configured_ Error 1
make[3]: Leaving directory `/openwrt/10.03/feeds/packages/libs/curl'
make[2]:
* [package/feeds/packages/curl/compile] Error 2
make[2]: Leaving directory `/openwrt/10.03'
make[1]: * openwrt/10.03/staging_dir/target-armeb_v5te_uClibc-0.9.30.1_eabi/stamp/.package_compile Error 2
make[1]: Leaving directory `/openwrt/10.03'
make:
* [world] Error 2

Changed 5 years ago by anonymous

comment:9 Changed 5 years ago by anonymous

The latest working rev. is 24298.
In 24299 the curl package was updated 7.19.6 -> 7.21.2 by acoul.
Unfortunately one of the patches are missing. (cross_compile)
I made it by hand and it seems to be good. (attached)
Try it please, and put it into the next rev. please.

comment:10 Changed 5 years ago by jow

Thanks, I've merged the cross compile patch again.

comment:11 Changed 5 years ago by jow

As for the original error, something odd is going on:

.../mips-openwrt-linux-uclibc/bin/as: error while loading shared libraries:
 /compile/openwrt/staging_dir/target-mips_uClibc-0.9.31/usr/lib/libz.so.1:
  ELF file data encoding not little-endian

I'm not sure whether the LD_LIBRARY_PATH trickery by configure is responsible for that, please retry with the current patch committed and report back.

comment:12 Changed 4 years ago by Marcos Tadeu <marcos@…>

This patch do not work in trunk 29484. configure.ac and configure is changed.
New patch attach

Changed 4 years ago by Marcos Tadeu <marcos@…>

comment:13 Changed 4 years ago by swalker

  • Resolution set to fixed
  • Status changed from reopened to closed

(Re)fixed in r29498 & r29841.

comment:14 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.