Modify

Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#8399 closed defect (fixed)

iptables fail to configure/compile

Reported by: buildster Owned by: jow
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Build machine: Ubuntu 10.04.1 LTS x86_64;
Target: kirkwood, dockstar;
Trunk: r24363

...
libtool: install: (cd /home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/ipkg-install/usr/lib &&
 { ln -s -f libip6tc.so.0.0.0 libip6tc.so || { rm -f libip6tc.so && ln -s libip6tc.so.0.0.0 libip6tc.so; }; })
libtool: install: /usr/bin/install -c libiptc/.libs/libip6tc.lai /home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/ipkg-install/usr/lib/libip6tc.la
libtool: install: warning: relinking `libiptc/libiptc.la'
libtool: install: (cd /home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10; /bin/bash /home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/libtool  --tag CC --mode=relink arm-openwrt-linux-uclibcgnueabi-gcc -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes -Winline -pipe -DXTABLES_LIBDIR=\"/usr/lib/iptables\" -DXTABLES_INTERNAL -I./include -I./include -I /home/builder/openwrt/build_dir/linux-kirkwood/linux-2.6.35.9/include -I /home/builder/openwrt/build_dir/linux-kirkwood/linux-2.6.35.9/include -Os -pipe -march=armv5te -mtune=marvell-f -funit-at-a-time -fhonour-copts -msoft-float -I/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/include -I/home/builder/openwrt/build_dir/linux-kirkwood/linux-2.6.35.9/arch/arm/include -version-info 0:0:0 -Wl,--no-as-needed -rdynamic -static-libgcc -o libiptc/libiptc.la -rpath /usr/lib libiptc/libip4tc.la libiptc/libip6tc.la -inst-prefix-dir /home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/ipkg-install)
libtool: relink: arm-openwrt-linux-uclibcgnueabi-gcc -shared  -fPIC -DPIC   -L/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/ipkg-install/usr/lib -L/usr/lib -lip4tc -lip6tc  -Os -march=armv5te -mtune=marvell-f -msoft-float -Wl,--no-as-needed   -Wl,-soname -Wl,libiptc.so.0 -o libiptc/.libs/libiptc.so.0.0.0
/home/builder/openwrt/staging_dir/toolchain-arm_v5te_gcc-4.3.3+cs_uClibc-0.9.31_eabi/lib/gcc/arm-openwrt-linux-uclibcgnueabi/4.3.3/../../../../arm-openwrt-linux-uclibcgnueabi/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/lib/libc.a: could not read symbols: File format not recognized
collect2: ld returned 1 exit status
libtool: install: error: relink `libiptc/libiptc.la' with the above command before installing it
make[6]: *** [install-libLTLIBRARIES] Error 1
make[6]: Leaving directory `/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10'
make[5]: *** [install-am] Error 2
make[5]: Leaving directory `/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10'
make[4]: *** [install-recursive] Error 1
make[4]: Leaving directory `/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10'
make[3]: *** [/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/.built] Error 2

Couldn't figure out why it wanted to link with /usr/lib/libc.a. Note that the build was done after making distclean.

Attachments (0)

Change History (10)

comment:1 Changed 7 years ago by buildster

Appreciate your quick fix! As of r24403, not an issue anymore.

comment:2 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r24375 and r24376 - thanks!

comment:3 Changed 7 years ago by buildster

  • Resolution fixed deleted
  • Status changed from closed to reopened

Thank you, jow, for fixing this issue. Unfortunately, it has returned as of r24733. Not sure what changes between r24403 and r24733 make the libtool linking libc from host, again. Some targets can skip incompatible libraries, but not kirkwood... from a distclean'ed build:

libtool: install: warning: relinking `libiptc/libiptc.la'
libtool: install: (cd /home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10; /bin/bash /home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/libtool  --tag CC --mode=relink arm-openwrt-linux-uclibcgnueabi-gcc -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes -Winline -pipe -DXTABLES_LIBDIR=\"/usr/lib/iptables\" -DXTABLES_INTERNAL -I./include -I./include -I /home/builder/openwrt/build_dir/linux-kirkwood/linux-2.6.35.9/include -I /home/builder/openwrt/build_dir/linux-kirkwood/linux-2.6.35.9/include -Os -pipe -march=armv5te -mtune=marvell-f -funit-at-a-time -fhonour-copts -msoft-float -I/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/include -I/home/builder/openwrt/build_dir/linux-kirkwood/linux-2.6.35.9/arch/arm/include -version-info 0:0:0 -Wl,--no-as-needed -rdynamic -static-libgcc -o libiptc/libiptc.la -rpath /usr/lib libiptc/libip4tc.la libiptc/libip6tc.la -inst-prefix-dir /home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/ipkg-install)
libtool: relink: arm-openwrt-linux-uclibcgnueabi-gcc -shared  -fPIC -DPIC   -L/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/ipkg-install/usr/lib -L/usr/lib -lip4tc -lip6tc  -Os -march=armv5te -mtune=marvell-f -msoft-float -Wl,--no-as-needed   -Wl,-soname -Wl,libiptc.so.0 -o libiptc/.libs/libiptc.so.0.0.0
/home/builder/openwrt/staging_dir/toolchain-arm_v5te_gcc-4.3.3+cs_uClibc-0.9.31_eabi/lib/gcc/arm-openwrt-linux-uclibcgnueabi/4.3.3/../../../../arm-openwrt-linux-uclibcgnueabi/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/lib/libc.a: could not read symbols: File format not recognized
collect2: ld returned 1 exit status
libtool: install: error: relink `libiptc/libiptc.la' with the above command before installing it
make[6]: *** [install-libLTLIBRARIES] Error 1
make[6]: Leaving directory `/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10'
make[5]: *** [install-am] Error 2
make[5]: Leaving directory `/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10'
make[4]: *** [install-recursive] Error 1
make[4]: Leaving directory `/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10'
make[3]: *** [/home/builder/openwrt/build_dir/linux-kirkwood/iptables-1.4.10/.built] Error 2
WARNING: skipping iptables-mod-ipsec -- package not selected
WARNING: skipping iptables-mod-ipset -- package not selected
WARNING: skipping iptables-mod-iprange -- package not selected
WARNING: skipping iptables-mod-ulog -- package not selected
WARNING: skipping iptables-mod-hashlimit -- package not selected
WARNING: skipping iptables-mod-tproxy -- package not selected
WARNING: skipping ip6tables -- package not selected
WARNING: skipping ip6tables-utils -- package not selected
WARNING: skipping libipq -- package not selected
make[3]: Target `compile' not remade because of errors.
make[3]: Leaving directory `/home/builder/openwrt/package/iptables'
make[2]: *** [package/iptables/compile] Error 2

comment:4 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from reopened to accepted

There was still stray host crap, please try r24740

comment:5 Changed 7 years ago by buildster

Appreciate jow's quick attention. r24740 still seems to have the same issue: including "-L/usr/lib" and skipping incompatible libraries when relink. Just notice your related fix in r24741. Trying it now...

comment:6 Changed 7 years ago by buildster

Just tried r24740 without r24741, r24741 without r24740, and both together. In all three cases, "-L/usr/lib" didn't go away. But, the patch in r24741 should have nuked it (sed'ed manually the relink command from the build log). Perhaps, it's added later or elsewhere.

comment:7 follow-up: Changed 7 years ago by jow

Please try r24752, another user reported success with that.
To only rebuild the needed parts use this command:

svn up
make tools/libtool/{clean,install} package/iptables/{clean,compile} V=99

comment:8 in reply to: ↑ 7 Changed 7 years ago by anonymous

Replying to jow:

Please try r24752, another user reported success with that.
To only rebuild the needed parts use this command:

svn up
make tools/libtool/{clean,install} package/iptables/{clean,compile} V=99

Thank you, jow! That fixes the problem, ridding of "-L/usr/lib" on relink. iptables build successfully for target kirkwood as of r24776. Appreciate the shortcut make command.

comment:9 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Issue confirmed fixed.

comment:10 Changed 3 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.