Modify

Opened 5 years ago

Closed 5 years ago

Last modified 22 months ago

#8786 closed defect (fixed)

Zlib 1.2.5 compilation is failing

Reported by: Ch. Exner <c.exe@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: zlib 25299 compile Cc:

Description

Hi OpenWRT-Team and developers,

when I try to build zlib version 1.2.5 under OpenWRT trunk revision 25299 it fails to compile. The error message is:

*** No rule to make target `libz.so.1.2.5'. Stop.

Please see the attaches files for more information.

Thanks.

Attachments (5)

zlib-1.2.5-build_log.txt (1.5 KB) - added by Ch. Exner <c.exe@…> 5 years ago.
Zlib 1.2.5 build log
openwrt_svn_25299-config.txt (125.9 KB) - added by Ch. Exner <c.exe@…> 5 years ago.
OpenWRT trunk revision 25299 config file
host_info-short.txt (1.0 KB) - added by Ch. Exner <c.exe@…> 5 years ago.
Short buildhost information
0001-always-enable-fhonour-copts.patch (1.4 KB) - added by dev@… 5 years ago.
patch to always enable -fhonour-copts in rules.mk
0001-rules.mk-always-enable-fhonour-copts.patch (1.5 KB) - added by Sven Bachmann <dev@…> 5 years ago.

Download all attachments as: .zip

Change History (14)

Changed 5 years ago by Ch. Exner <c.exe@…>

Zlib 1.2.5 build log

Changed 5 years ago by Ch. Exner <c.exe@…>

OpenWRT trunk revision 25299 config file

Changed 5 years ago by Ch. Exner <c.exe@…>

Short buildhost information

comment:1 Changed 5 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

None of the buildbots is seeing zlib issues, I don't see them here either - therfore I assume its an issue with your environment (automake, libtool?)

comment:2 Changed 5 years ago by dev@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Yes its right, the problem is the build environment but it can (should) be fixed in OpenWrt (because my build env is OpenWrt - but I divided toolchain and firmware into two projects as can be seen on Bug #9131).

Thats zlibs output when using the same build environment with the extern toolchain method:

Tested arm-openwrt-linux-uclibcgnueabi-gcc -w -c -Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time -msoft-float -fpic -fPIC ztest10501.c
cc1: note: someone does not honour COPTS correctly, passed 0 times
Tested arm-openwrt-linux-uclibcgnueabi-gcc -shared -Wl,-soname,libz.so.1 -Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time -msoft-float -fpic -fPIC -o ztest10501.so ztest10501.o
No shared library support; try without defining CC and CFLAGS
Building static library libz.a version 1.2.5 with arm-openwrt-linux-uclibcgnueabi-gcc.

Problem is, in rules.mk the '-fhonour-copts' flag is only set when external toolchain is not set. And without this, zlib will not build the needed shared library.

So the solution seems easy to me: enable -fhonour-copts also for external toolchains.

Thanks in advance,

Sven

Changed 5 years ago by dev@…

patch to always enable -fhonour-copts in rules.mk

comment:3 Changed 5 years ago by jow

  • Milestone changed from Backfire 10.03.1 to Attitude Adjustment (trunk)

Changed 5 years ago by Sven Bachmann <dev@…>

comment:4 Changed 5 years ago by Sven Bachmann <dev@…>

comment:5 follow-up: Changed 5 years ago by mirko

external compilers may fail because not recognizing '-fhonour-copts'

what's about appending '-fhonour-copts' always just for zlib (as 'TARGET_CFLAGS += -fhonour-copts' in package/zlib?)

comment:6 in reply to: ↑ 5 Changed 5 years ago by mirko

Replying to mirko:

external compilers may fail because not recognizing '-fhonour-copts'

what's about appending '-fhonour-copts' always just for zlib (as 'TARGET_CFLAGS += -fhonour-copts' in package/zlib?)

That doesn't make sense, since compilers not recognizing '-fhonour-copts' will still fail.

comment:7 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in r27771

comment:8 Changed 5 years ago by martonmiklosqdev@…

Hello,

I am trying to compile the libyasdi package using the OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1 (backfire rc5). I have downloaded the package makefiles from the svn trunk. The -fhonour-copts is present in the CFLAGS, but the compilation still failin. Any ideas?

comment:9 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.