Modify

Opened 5 years ago

Closed 3 years ago

Last modified 22 months ago

#8820 closed defect (fixed)

Not build transmission

Reported by: sav Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Not build transmission 2.20

mipsel-openwrt-linux-gnu-gcc -DPACKAGE_NAME=\"transmission\" -DPACKAGE_TARNAME=\"transmission\" -DPACKAGE_VERSION=\"2.20\" -DPACKAGE_STRING=\"transmission\ 2.20\" -DPACKAGE_BUGREPORT=\"http://trac.transmissionbt.com/newticket\" -DPACKAGE_URL=\"\" -DPACKAGE=\"transmission\" -DVERSION=\"2.20\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DSTDC_HEADERS=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_ICONV_OPEN=1 -DHAVE_PREAD=1 -DHAVE_PWRITE=1 -DHAVE_DAEMON=1 -DHAVE_DIRNAME=1 -DHAVE_BASENAME=1 -DHAVE_STRCASECMP=1 -DHAVE_LOCALTIME_R=1 -DHAVE_FALLOCATE64=1 -DHAVE_POSIX_FALLOCATE=1 -DHAVE_MEMMEM=1 -DHAVE_STRSEP=1 -DHAVE_STRTOLD=1 -DHAVE_SYSLOG=1 -DHAVE_VALLOC=1 -DHAVE_GETPAGESIZE=1 -DHAVE_POSIX_MEMALIGN=1 -DHAVE_STATVFS=1 -DHAVE_PTHREAD=1 -DHAVE__TMP_DUMMY1_ZLIB_H=1 -DHAVE_ZLIB=1 -D_FILE_OFFSET_BITS=64 -DHAVE_LSEEK64=1 -DHAVE_DECL_POSIX_FADVISE=1 -DHAVE_POSIX_FADVISE=1 -DWITH_INOTIFY=1 -DHAVE_SYS_STATVFS_H=1 -DTR_LIGHTWEIGHT=1 -I.  -I. -I.. -I../third-party/ -D__TRANSMISSION__ -DPACKAGE_DATA_DIR=\""/usr/share"\" -I/home/sysadmin/wl500/OpenWrt/SDK/staging_dir/target-mipsel_eglibc-2.12/usr/include -I/home/sysadmin/wl500/OpenWrt/SDK/staging_dir/target-mipsel_eglibc-2.12/include -I/home/sysadmin/wl500/OpenWrt/SDK/staging_dir/toolchain-mipsel_gcc-4.5.2_eglibc-2.12/usr/include -I/home/sysadmin/wl500/OpenWrt/SDK/staging_dir/toolchain-mipsel_gcc-4.5.2_eglibc-2.12/include  -DNDEBUG -I../third-party/dht -I/home/sysadmin/wl500/OpenWrt/SDK/staging_dir/target-mipsel_eglibc-2.12/usr//include -I/home/sysadmin/wl500/OpenWrt/SDK/staging_dir/target-mipsel_eglibc-2.12/usr//include -I/home/sysadmin/wl500/OpenWrt/SDK/staging_dir/target-mipsel_eglibc-2.12/usr//include -pthread  -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -msoft-float -D_GNU_SOURCE -MT fdlimit.o -MD -MP -MF .deps/fdlimit.Tpo -c -o fdlimit.o fdlimit.c
In file included from /home/sysadmin/wl500/OpenWrt/SDK/staging_dir/toolchain-mipsel_gcc-4.5.2_eglibc-2.12/bin/../lib/gcc/mipsel-openwrt-linux-gnu/4.5.2/../../../../mipsel-openwrt-linux-gnu/sys-include/fcntl.h:34:0,
                 from fdlimit.c:49:
/home/sysadmin/wl500/OpenWrt/SDK/staging_dir/toolchain-mipsel_gcc-4.5.2_eglibc-2.12/bin/../lib/gcc/mipsel-openwrt-linux-gnu/4.5.2/../../../../mipsel-openwrt-linux-gnu/sys-include/bits/fcntl.h:288:12: error: conflicting types for 'fallocate64'
fdlimit.c:36:14: note: previous declaration of 'fallocate64' was here
make[5]: *** [fdlimit.o] Error 1
make[5]: Leaving directory `/home/sysadmin/wl500/OpenWrt/SDK/build_dir/target-mipsel_eglibc-2.12/transmission-2.20/libtransmission'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/sysadmin/wl500/OpenWrt/SDK/build_dir/target-mipsel_eglibc-2.12/transmission-2.20'
make[3]: *** [/home/sysadmin/wl500/OpenWrt/SDK/build_dir/target-mipsel_eglibc-2.12/transmission-2.20/.built] Error 2
make[3]: Leaving directory `/home/sysadmin/wl500/OpenWrt/SDK/package/transmission'
make[2]: *** [package/transmission/compile] Error 2

Attachments (1)

001-no_fallocate64_def.patch (354 bytes) - added by cederigo 5 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 follow-up: Changed 5 years ago by mandgeo@…

I don't realy understand what you are trying to say, but i saw "transmission" and i thought it was o good place to post.

Transmission package is missing from /snapshots/trunk/x86/packages/. What happend? Will the problem be fixed?

And another question, this time not related to transmission... The latest x86 trunk build includes support for atheros ar9271?

Please excuse me if i posted in the wrong place.

comment:2 in reply to: ↑ 1 Changed 5 years ago by sav

Replying to mandgeo@…:

I don't realy understand what you are trying to say, but i saw "transmission" and i thought it was o good place to post.

Transmission package is missing from /snapshots/trunk/x86/packages/. What happend? Will the problem be fixed?

And another question, this time not related to transmission... The latest x86 trunk build includes support for atheros ar9271?

Please excuse me if i posted in the wrong place.

I built a transmisson for wl500(MIPS32), but not for x86 ;-))
croscompile in the Ubuntu x86-64!

comment:3 Changed 5 years ago by anonymous

"croscompile in the Ubuntu x86-64" ...and for noobs, how should i do that? :D

Changed 5 years ago by cederigo

comment:4 follow-up: Changed 5 years ago by cederigo

same problem here. ( on trunk )
i think the problem is that since version 2.11 of glibc/eglibc fallocate64 is already defined.
This patch removes the definition BUT what about uclibc, earlier versions? how to handle this properly??

comment:5 in reply to: ↑ 4 Changed 5 years ago by sav

Replying to cederigo:

same problem here. ( on trunk )
i think the problem is that since version 2.11 of glibc/eglibc fallocate64 is already defined.
This patch removes the definition BUT what about uclibc, earlier versions? how to handle this properly??

Thanks. This works well!

comment:6 Changed 3 years ago by jogo

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed in attitude adjustment and trunk as both use newer eglibc and transmission versions. If not, just reopen the ticket.

comment:7 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.