Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#8835 closed defect (worksforme)

The Change from 25419 to 25455 leads to a network error

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03.1 RC4
Keywords: Cc:


with 25419 /etc/init.d/network restart works without error.
with 25455 /etc/init.d/network restart produces an error.
This error appears also in the system log

the error is do_sysctl not found in /etc/hotplug.d/iface/10-rootes

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by swalker

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r25474.

comment:2 Changed 5 years ago by mikebrady@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Just using Backfire (10.03.1-RC6, r28215) on an NSLU2 and this problem is still there, i.e. do_sysctl is missing from /etc/hotplug.d/iface/10-routes. Causing problems with radvd/ipv6.

comment:3 Changed 5 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

Cannot reproduce it. do_sysctl() is in /lib/network/ which is sourced by "include /lib/network" within "/etc/hotplug.d/iface/10-routes" in the "ifup" branch.

comment:4 Changed 5 years ago by

Apologies -- I think what happened was that I was working off sources checked out with:

svn checkout svn://

When I redid everything taking sources with:

svn checkout svn://

I got the fixed version.

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.