Modify

Opened 6 years ago

Closed 6 years ago

#8861 closed defect (fixed)

devices connected to sbb->pci bridge not enumerated correctly

Reported by: zakwasny@… Owned by: hauke
Priority: normal Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: Cc:

Description

router: linksys WRT-150N
OpenWrt: built from latest trunk

wirless card connected to ssb -> pci bridge is not enumerated, lspci shows only bridge itself with no devices attached.

OpenWrt boot messages:

Linux version 2.6.36.2 (xfd@Ubuntu) (gcc version 4.3.3 (GCC) ) #1 Sun Feb 13 20:00:26 CET 2011
CPU revision is: 00029006 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x03, vendor 0x4243)
ssb: Core 1 found: Fast Ethernet (cc 0x806, rev 0x06, vendor 0x4243)
ssb: Core 2 found: Fast Ethernet (cc 0x806, rev 0x06, vendor 0x4243)
ssb: Core 3 found: USB 1.1 Hostdev (cc 0x808, rev 0x03, vendor 0x4243)
ssb: Core 4 found: PCI (cc 0x804, rev 0x08, vendor 0x4243)
ssb: Core 5 found: MIPS 3302 (cc 0x816, rev 0x03, vendor 0x4243)
ssb: Core 6 found: V90 (cc 0x807, rev 0x02, vendor 0x4243)
ssb: Core 7 found: IPSEC (cc 0x80B, rev 0x00, vendor 0x4243)
ssb: Core 8 found: MEMC SDRAM (cc 0x80F, rev 0x02, vendor 0x4243)
ssb: chipcommon status is 0x0
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0806, irq 4 => 4
ssb: set_irq: core 0x0806, irq 5 => 5
ssb: set_irq: core 0x0808, irq 6 => 2
ssb: set_irq: core 0x0804, irq 2 => 6
ssb: after irq reconfiguration
ssb: core 0x0800, irq : 2(S)  3* 4  5  6  D  I
ssb: core 0x0806, irq : 2(S)  3  4* 5  6  D  I
ssb: core 0x0806, irq : 2(S)  3  4  5* 6  D  I
ssb: core 0x0808, irq : 2(S)* 3  4  5  6  D  I
ssb: core 0x0804, irq : 2(S)  3  4  5  6* D  I
ssb: core 0x0816, irq : 2(S)* 3  4  5  6  D  I
ssb: core 0x0807, irq : 2(S)* 3  4  5  6  D  I
ssb: core 0x080b, irq : 2(S)* 3  4  5  6  D  I
ssb: core 0x080f, irq : 2(S)  3  4  5  6  D  I*
ssb: Sonics Silicon Backplane found at address 0x18000000
Serial init done.
Determined physical RAM map:
 memory: 04000000 @ 00000000 (usable)
PCI: Unknown option `lastbus=1'
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00004000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00004000
On node 0 totalpages: 16384
free_area_init_node: node 0, pgdat 802886c0, node_mem_map 81000000
  Normal zone: 128 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 16256 pages, LIFO batch:3
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200 pci=lastbus=1
PID hash table entries: 256 (order: -2, 1024 bytes)
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 16kB, 2-way, VIPT, cache aliases, linesize 16 bytes
Memory: 62076k/65536k available (2254k kernel code, 3460k reserved, 337k data, 152k init, 0k highmem)
NR_IRQS:128
console [ttyS0] enabled
Calibrating delay loop... 263.16 BogoMIPS (lpj=526336)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
ssb: PCIcore in host mode found
ssb: CardBus slot detected
PCI: Fixing up bridge 0000:00:00.0
PCI: Setting latency timer of device 0000:00:00.0 to 64
PCI: Fixing up device 0000:00:00.0
PCI: Fixing latency timer of device 0000:00:00.0 to 168
pci 0000:00:00.0: reg 10: [mem 0x00000000-0x00001fff]
pci 0000:00:00.0: reg 14: [mem 0x00000000-0x07ffffff pref]
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
UDP hash table entries: 256 (order: 0, 4096 bytes)
UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
NET: Registered protocol family 1
PCI: CLS 0 bytes, default 32
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
msgmni has been set to 121
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 2 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250.0: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
flash init: 0x1c000000 0x02000000
Physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x0000ec Chip ID 0x0022a2
Physically mapped flash: Found an alias at 0x400000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x800000 for the chip at 0x0
Physically mapped flash: Found an alias at 0xc00000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1000000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1400000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1800000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1c00000 for the chip at 0x0
Amd/Fujitsu Extended Query Table at 0x0040
  Newer Samsung flash detected, should be compatible with Amd/Fujitsu.
  Fixed Samsung's Amd/Fujitsu Extended Query version from 3.3 to 1.3.
  Amd/Fujitsu Extended Query version 1.3.
number of CFI chips: 1
Flash device: 0x400000 at 0x1fc00000
bootloader size: 262144
Looking for dual image
TRX offset : 0
Creating 4 MTD partitions on "Physically mapped flash":
0x000000000000-0x000000040000 : "cfe"
0x000000040000-0x0000003f0000 : "linux"
0x000000115c00-0x0000003f0000 : "rootfs"
mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2E0000, len=110000
0x0000002e0000-0x0000003f0000 : "rootfs_data"
0x0000003f0000-0x000000400000 : "nvram"
b44: b44.c:v2.0
b44 ssb0:0: eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:1d:7e:3c:5d:69
b44 ssb0:1: eth1: PHY Reset would not complete
b44 ssb0:1: eth1: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:88:88:88:00:2a
BCM47xx Watchdog Timer enabled (30 seconds, nowayout)
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 152k freed
diag: Detected 'Linksys WRT160N'
b44 ssb0:0: eth0: Link is up at 100 Mbps, full duplex
b44 ssb0:0: eth0: Flow control is off for TX and off for RX
roboswitch: Probing device eth0: found a 5325! It's a 5350.
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
b44 ssb0:0: eth0: powering down PHY
b44 ssb0:0: eth0: Link is up at 100 Mbps, full duplex
b44 ssb0:0: eth0: Flow control is off for TX and off for RX
device eth0 entered promiscuous mode
br-lan: port 1(eth0) entering forwarding state
br-lan: port 1(eth0) entering forwarding state
b44 ssb0:1: eth1: Link is up at 100 Mbps, full duplex
b44 ssb0:1: eth1: Flow control is off for TX and off for RX
b44 ssb0:1: eth1: powering down PHY
b44 ssb0:1: eth1: Link is up at 100 Mbps, full duplex
b44 ssb0:1: eth1: Flow control is off for TX and off for RX
br-lan: port 1(eth0) entering forwarding state
br-lan: port 1(eth0) entering forwarding state
br-lan: port 1(eth0) entering forwarding state
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
wl: module license 'unspecified' taints kernel.
Disabling lock debugging due to kernel taint
NTFS driver 2.1.29 [Flags: R/O MODULE].
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 24
nf_conntrack version 0.5.0 (972 buckets, 3888 max)
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ohci_hcd ssb0:2: SSB OHCI Controller
ohci_hcd ssb0:2: new USB bus registered, assigned bus number 1
ohci_hcd ssb0:2: irq 2, io mem 0x18003000
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.

lspci:

-[0000:00]-+-00.0  14e4:4704

lspci from Tomato, kernel 2.6.22.19:

-[0000:00]-+-00.0  14e4:0800
           +-01.0  14e4:4713
           +-02.0  14e4:4713
           +-03.0  14e4:4716
           +-04.0-[01]--+-00.0  14e4:4704
           |            \-01.0  14e4:4321
           +-05.0  14e4:0816
           +-06.0  14e4:4712
           +-07.0  14e4:4718
           \-08.0  14e4:080f

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by zakwasny@…

Please change milestone to none. I selected wrong one.

comment:2 follow-ups: Changed 6 years ago by florian

  • Resolution set to invalid
  • Status changed from new to closed

Your analysis is not quite correct, the original SSB code that is used by the Tomato firmwares fakes the SSB bus as being a PCI bus, this is not how that really works.

comment:3 in reply to: ↑ 2 Changed 6 years ago by KanjiMonster

Replying to florian:

Your analysis is not quite correct, the original SSB code that is used by the Tomato firmwares fakes the SSB bus as being a PCI bus, this is not how that really works.

Well then where's the wifi (14e4:4321)?

comment:4 in reply to: ↑ 2 Changed 6 years ago by anonymous

Replying to florian:

Your analysis is not quite correct, the original SSB code that is used by the Tomato firmwares fakes the SSB bus as being a PCI bus, this is not how that really works.

I don't know indeed how it should work, but my observation from other routers dmesg is that wifi card is enumerated as PCI device, and in my case this is not true. Also I tried both drivers b43 and broadcom-wl and both loads without info that any hardware was found.

comment:5 follow-up: Changed 6 years ago by RealOpty <realopty@…>

  • Resolution invalid deleted
  • Status changed from closed to reopened

Ive reopened this bug because im experiencing the same issues with my router. I have a Netgear WNR834B V2. the wifi is the same BRCM4321. When i did 'lspci' I had similar results. something to do with SSB i suspect.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 6 years ago by zakwasny@…

Replying to RealOpty <realopty@…>:

Ive reopened this bug because im experiencing the same issues with my router. I have a Netgear WNR834B V2. the wifi is the same BRCM4321. When i did 'lspci' I had similar results. something to do with SSB i suspect.

In my case problem was caused by incorrect nvram settings: cardbus=1. After change to 0 pci bus is correctly enumerated. Also in my router (WRT150N) all settings related to WIFI are prefixed with: pci/1/1/, native Broadcom k2.6 drivers don't support that, check this on your router if drivers don't load properly.

comment:7 in reply to: ↑ 6 Changed 6 years ago by anonymous

Replying to zakwasny@…:

Replying to RealOpty <realopty@…>:

Ive reopened this bug because im experiencing the same issues with my router. I have a Netgear WNR834B V2. the wifi is the same BRCM4321. When i did 'lspci' I had similar results. something to do with SSB i suspect.

In my case problem was caused by incorrect nvram settings: cardbus=1. After change to 0 pci bus is correctly enumerated. Also in my router (WRT150N) all settings related to WIFI are prefixed with: pci/1/1/, native Broadcom k2.6 drivers don't support that, check this on your router if drivers don't load properly.

Thanks for the tip! i checked my nvram setting and its cardbus=1. Ill be compiling a new build tonight for testing :D thanks again

comment:8 Changed 6 years ago by Realopty

I just was reading the changelogs. check out r26736 and r26733 Hauke just added the firmware and so on.

SWEET!

comment:9 follow-up: Changed 6 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from reopened to accepted

Please try svn trunk with at least version r26801 and post the dmesg output. I think we have to add the same workaround used on the Netgear WNR834B V2 for this device. Could you please also post the nvram content so we can identify the device?

comment:10 in reply to: ↑ 9 Changed 6 years ago by zakwasny@…

Replying to hauke:

Please try svn trunk with at least version r26801 and post the dmesg output. I think we have to add the same workaround used on the Netgear WNR834B V2 for this device. Could you please also post the nvram content so we can identify the device?

WRT150N v1.1 nvram:

boot_hw_model=WRT150N 
boot_hw_ver=1.1 
boardtype=0x0472 
boardnum=42 
boardrev=0x11 
boardflags=0x0010 
sromrev=2 
clkfreq=264 
sdram_init=0x054B 
sdram_config=0x0062 
sdram_refresh=0x0 
sdram_ncdl=0x0 
cardbus=1 
parkid=0 
et0phyaddr=30 
et0mdcport=0 
et0macaddr=00:88:88:88:00:2a 
et1phyaddr=4 
et1mdcport=0 
et1macaddr=00:88:88:88:00:2a 
lan_ipaddr=192.168.1.1 
lan_netmask=255.255.255.0 
boot_wait=off 
wait_time=3 
mfg_wait=on 
tftpd_ipaddr=192.168.1.254 
dl_ram_addr=a0001000 
os_ram_addr=80001000 
os_flash_addr=bfc40000 
scratch=a0180000 
watchdog=5000 
bootnv_ver=5 
blink_diag_led=1 
diag_gpio=1 
pci/1/1/aa2g=3 
pci/1/1/ag0=2 
pci/1/1/ag1=2 
pci/1/1/boardflags=0x200 
pci/1/1/boardflags2=0x0000 
pci/1/1/boardrev=0x4b 
pci/1/1/boardtype=0x46d 
pci/1/1/boardvendor=0x14e4 
pci/1/1/bw40po=0 
pci/1/1/bwduppo=0 
pci/1/1/ccdpo=0 
pci/1/1/cck2gpo=0 
pci/1/1/ccode=0 
pci/1/1/devid=0x4329 
pci/1/1/itt2ga0=0 
pci/1/1/itt2ga1=0 
pci/1/1/ledbh0=8 
pci/1/1/ledbh1=-1 
pci/1/1/ledbh2=-1 
pci/1/1/ledbh3=-1 
pci/1/1/leddc=0xffff 
pci/1/1/macaddr=00:88:88:88:00:2a 
pci/1/1/maxp2ga0=0 
pci/1/1/maxp2ga1=0 
pci/1/1/mcs2gpo0=0 
pci/1/1/mcs2gpo1=0 
pci/1/1/mcs2gpo2=0 
pci/1/1/mcs2gpo3=0 
pci/1/1/mcs2gpo4=0 
pci/1/1/mcs2gpo5=0 
pci/1/1/mcs2gpo6=0 
pci/1/1/mcs2gpo7=0 
pci/1/1/ofdm2gpo=0 
pci/1/1/pa2gw0a0=0 
pci/1/1/pa2gw0a1=0 
pci/1/1/pa2gw1a0=0 
pci/1/1/pa2gw1a1=0 
pci/1/1/pa2gw2a0=0 
pci/1/1/pa2gw2a1=0 
pci/1/1/pa2gw3a0=0 
pci/1/1/pa2gw3a1=0 
pci/1/1/regrev=0 
pci/1/1/sromrev=4 
pci/1/1/stbcpo=0 
pci/1/1/txpid2ga0=91 
pci/1/1/txpid2ga1=91 
pci/1/1/txpt2g=0x36 
pci/1/1/venid=0x14e4 
pci/1/1/txchain=3 
pci/1/1/rxchain=3 
pci/1/1/antswitch=0

comment:11 Changed 6 years ago by hauke

  • Resolution set to fixed
  • Status changed from accepted to closed

The workaround for the Netgear WNR834B V2 should also be activated for the WRT150N v1.1, as they have the same boardtype in nvram. There should be no modification to the nvram be needed to find the wireless module. This was fixed in r26801.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.