Modify

Opened 10 years ago

Closed 9 years ago

Last modified 2 years ago

#892 closed defect (worksforme)

busybox - cascading promt after using the more or less commands

Reported by: KillaB Owned by: nico
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

Just as the title states, more and less commands cause the prompt to cascade. Tested on a few builds between 5195 to current on WGT634U and DG834G. It can be recreated via SSH, Telnet and Terminal. Not sure at which build this problem first appeared.

Example:
#

root@OpenWrt:~#

root@OpenWrt:~#

root@OpenWrt:~#

Attachments (0)

Change History (19)

comment:1 Changed 10 years ago by KillaB

Better example:

#
  root@OpenWrt:~#
                  root@OpenWrt:~#
                                  root@OpenWrt:~#
                                                  root@OpenWrt:~#
                                                                  root@OpenWrt:~#

comment:2 Changed 10 years ago by KillaB

Whoops, forgot to mention this only happens when escaping with CTRL_C. Didn't realize you could quit with q

comment:3 Changed 10 years ago by florian

Which terminal do you use ?

comment:4 Changed 10 years ago by KillaB

Windows HyperTerminal. This is irrelavent though as it's happening with PuTTY and telnet as well.

Please see my additional comment about it only happening when escaping with CTRL_C. Escaping with q works.

comment:5 Changed 10 years ago by KillaB

I haven't used Kamikaze since build 3587 (currently running 5334).

Could it be possible that this problem arose in build 4774?

https://dev.openwrt.org/changeset/4774

comment:6 Changed 10 years ago by florian

Yes, could be related, please have a try with the previous change. Thanks.

comment:7 Changed 10 years ago by KillaB

Reverted the changes and it works great now.
So this proves the problem is with the less command in busybox 1.2.1-1

Since I don't know the reasoning behind changing more to less (still a Linux amateur) and I don't use it everyday like some of you guys, I'll let you decide if anything needs to be done about it.

I'm sure it's not a problem for those of us who have a habit of using Ctrl_C to start using q to quit instead...seeing as it's probably the proper method.

Cheers,
Jason

comment:8 Changed 10 years ago by mbm

  • Owner changed from developers to mbm

comment:9 Changed 10 years ago by KillaB

I browsed the source of less.c on the Busybox site, but I'm not much of a programmer and couldn't find any reference to the problem.

Would it be hard to move to the latest stable build of Busybox (1.2.2.1) ?

comment:10 Changed 10 years ago by KillaB

FYI...
Built 5664 last night with BusyBox 1.2.2.1 and the problem is still there.
Anyone able to test BusyBox outside of OpenWrt?

comment:11 Changed 10 years ago by MMCM

I sometimes have this problem too, when viewing binary files with less (putty ssh session). I think some binary data can change terminal settings, so it's not busybox's fault.

KillaB: The advantage of less over more is that you can scroll back and forth through the file.

Don't view binary files, less even warns you ;-)

comment:12 Changed 10 years ago by KillaB

This problem happens with less on any file, regardless of size.

I'll ask in the forums if this problem exists in the new BusyBox 1.2.1 package for Whiterussian.

comment:13 Changed 10 years ago by KillaB

Ticket I opened with BusyBox has been closed (please see less.c and Config.in)
http://busybox.net/bugs/view.php?id=1121

Perhaps someone with more experience can create a patch for 1.2.1 and see if it works. Looks like there have been 4 diffs since the BusyBox build I'm running on Kamikaze r5195.

comment:14 Changed 10 years ago by nico

  • Owner changed from mbm to nico
  • Status changed from new to assigned

comment:15 Changed 10 years ago by KillaB

Looks like the above BusyBox patches have made it into the 1.4.0 release, so I guess we'll have to wait until Kamikaze upgrades to 1.4.x to test.

comment:16 Changed 9 years ago by KillaB

This problem appears to be fixed in 1.4.0.
Tested using forum2006's VMWare image here: http://forum.openwrt.org/viewtopic.php?id=7879

comment:17 Changed 9 years ago by framer99

I've always seens this same problem using busybox vi applet on a soekris console port and scrolling down too fast and too far, or pasting in too much text.

I added the vim package and use that... and no more problems.

running stty -a >>/tmp/out before and after the cascading prompt problem occurs(stty sane then gets you back to working) shows a few settings that get out of wack.

But when vim turned out to work fine, i gave up trying to figure things out.

oh yeah, just before it goes to cascading prompt, the phrase "Alarm Clock" appears. Every time.

comment:18 Changed 9 years ago by mbm

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:19 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.