Modify

Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#9044 closed defect (fixed)

ncurses{w} doesn't install ncurses{w}5-config

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

ncurses (both libncurses and libncursesw) do not install ncurses{w}5-config. This leads to build failures in packages that rely on ncurses{w}5-config. For example, alsa-utils-1.0.24.2 fail to build due to that (however, alsa-utils-1.0.23 used to build fine, though it included /usr/include/ncurses in cross-compailation (using the host's ncurses-config), but it didn't cause configure to exit at 1.0.23 alsa-utils version).

The attached patch fixes the issue, thus also fixing compilation for packages like alsa-utils.

Attachments (1)

ncurses-install-config.patch (1.1 KB) - added by anonymous 6 years ago.
the patch for ncurses

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by anonymous

the patch for ncurses

comment:1 Changed 6 years ago by anonymous

In case this patch gets accepted i kindly ask to backport it to backfire, because this problem is also relevant for backfire. If you guys could backport libncursesw, too, would be great :) Currently we have to maintain additional ncursesw package in backfire to have wide version of ncurses there -\

comment:2 Changed 6 years ago by anonymous

Could someone react to this bug report, please?

comment:3 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Committed in r26255 - thanks!

comment:4 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.