Modify

Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#9992 closed enhancement (fixed)

Samba 3.6 upgrade for performance and smb2

Reported by: Todd Richmond <todd_richmond@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: samba Cc:

Description

Samba 3.6 now has support for SMB2 and significantly better performance with an async back-end. Smbd performance is THE limiting factor for throughput on any gigabit router with 400Mhz or less CPU. Even newer 680Mhz CPUs are maxed out around the same throughput as USB (I have one of each)

the trunk and backfire versions of Samba is 3.0.24 which is far out-of-date and it looks like some other router distros have 3.5 but they wouldn't work on my ar71xx router

My goal is to do some configuration tweaks for 3.6 to optimize performance for a home lan where openwrt is used as a full media/file server and then contribute those back

Attachments (6)

samba3x.tar.gz (3.4 KB) - added by Todd Richmond <todd_richmond@…> 5 years ago.
samba 3.6 build files
samba3x.tar.2.gz (11.8 KB) - added by Todd Richmond <todd_richmond@…> 5 years ago.
smb3x with fully shared libraries
samba-upgrade.patch (65.0 KB) - added by written 5 years ago.
samba3x.tar.3.gz (14.9 KB) - added by Todd Richmond <todd_richmond@…> 5 years ago.
patch integrating compile time cleanup and other minor fixes
samba3x.tar.4.gz (16.4 KB) - added by Todd Richmond <todd_richmond@…> 5 years ago.
more bug fixes, cleanup and size reduction - Makefile.in submitted to samba.org for review
samba3x.tar.5.gz (32.0 KB) - added by alphasparc@… 5 years ago.
Remove unnesssary socket options and cleanup smb conf template

Download all attachments as: .zip

Change History (56)

comment:1 Changed 5 years ago by anonymous

Can you submit a patch please?

comment:2 Changed 5 years ago by anonymous

AFAIK samba 3.0.24 provided with OpenWrt is hardly patched to produce significantly smaller binaries and use much less RAM compared to original one.
Would it be possible to adopt samba 3.6 to openwrt maintaining those advantages?

comment:3 Changed 5 years ago by anonymous

comment:4 Changed 5 years ago by arokh <trondah@…>

Even FTP throughput is limited by CPU on my WNDR3700 680 MHz router, and there is no way a bigger and more bloated Samba version will beat FTP performance.

Other than features and compatibility there is no need to upgrade the Samba version. As pointed out above, 3.0.24 is heavily patched to strip away unneeded features and make the binary much smaller.

Even with AVM patch, 3.3.14 is several times larger than 3.0.24. I think it's safe to say that even if you ported the AVM patches to 3.6, you would have an even larger binary that would consume more RAM/ROM and be more CPU intensive than the previous versions.

Pretty much a dead end if you ask me, what's needed is more powerful routers.

comment:5 Changed 5 years ago by todd_richmond@…

Had to create a completely new opkg makefile to work around several build and runtime failures and now have 3.6 running, but it is big beyond belief. I got SMB2 to work as well, but haven't been able to configure any perf improvement yet - not slower though either. None of the patches for Vista compat are required, but it will take some definite effort to prune down the file sizes. Max speeds of 15/11 MB/sec (read / write) on a 680Mhz router.

I'll take a stab at shinkage next week

comment:6 Changed 5 years ago by loswillios

IIRC I read something about samba4 having an embedded option. Maybe that's worth a try?

comment:7 Changed 5 years ago by nbd

If you have a fully working version of samba 3.6, feel free to post it here even if it is too big. I can probably help with stripping it down when I find the time for it.

comment:8 Changed 5 years ago by jow

Maybe we should maintain various samba versions in parallel?

comment:9 Changed 5 years ago by Todd Richmond <todd_richmond@…>

Ok - let me package up my makefile, patch dir and config files.

I did a very quick hack to convert all the smbd/nmbd shared .o files into a single library just to see how much could be stripped by linking out from main() instead of including everything, but that surprisingly only saved 200k out of 8mb. I still need to retry w/o winbindd and stripping out the debug comment strings (debug symbols already removed with gcc -s), but doubt that will do much more

Changed 5 years ago by Todd Richmond <todd_richmond@…>

samba 3.6 build files

comment:10 Changed 5 years ago by Todd Richmond <todd_richmond@…>

I created new patches and config files for "samba3x". There will be a samba4x later on (I did not see any work on size reduction for embedded systems though). This is my first OpenWrt package so I'm not sure if there are any other required files. The big difference is that there are now samba3x-common, samba3x-server and samba3x-client targets - most people will just want -server. I also use the more standard /usr/sbin path for smbd and nmbd

Config files can be shared with the existing 3.0.x release. security = user is set with fallback to allow guest access. The only var not supported by 30x is for SMB2 support but that fails silently

There is a ugly hack to ignore the abort when setuid and setgid() fail. Files are still owned by the correct smbpasswd user so I'm not sure if setuid is absolutely required on a router system w/ no user access

Creating a .lib from all the shared smbd objs saved 200k out of 10mb so there needs to be more fundamental work done to reduce sizes

comment:11 follow-up: Changed 5 years ago by anonymous

This version is working very well on my wndr3700. 3.0.x didn't work with win7 and 3.3.14 had problems with large files.

Using "samba_cv_USE_SETREUID=yes" you can get rid of this setuid/setgid hack.
Also i would add "samba_cv_HAVE_IFACE_IFCONF=yes" and "samba_cv_HAVE_KERNEL_OPLOCKS_LINUX=yes".

comment:12 in reply to: ↑ 11 Changed 5 years ago by anonymous

Also i would add "samba_cv_HAVE_IFACE_IFCONF=yes" and "samba_cv_HAVE_KERNEL_OPLOCKS_LINUX=yes".

a little correction, there should be "libreplace_cv_HAVE_IFACE_IFCONF=yes" instead of "samba_cv_HAVE_IFACE_IFCONF=yes".

comment:13 Changed 5 years ago by Todd Richmond <todd_richmond@…>

Thx for the tip. I broke down and am completely redoing all the linkage for every program (20 or so) and have reduced the disk usage by > 90% (less for smbd/nmbd though unfortunately)! I should be done tomorrow, but am running into a problem with the net command. It will still be too large for smaller routers, but should be ok for bigger ones. Will post again when done

Changed 5 years ago by Todd Richmond <todd_richmond@…>

smb3x with fully shared libraries

comment:14 Changed 5 years ago by Todd Richmond <todd_richmond@…>

Newer file converts everything to share libsmbclient.so which reduces nmbd/smbd size by 50% (still remains huge), but client programs are reduced by > 95%. I also included more configure options in Makefile as suggested in previous comments.

Next step is to review the AVM patch set to pick of some of the more important changes. First up is to see if I can remove one of the child processes. I'll post after the next significant reduction, but would love feedback on this update

comment:15 Changed 5 years ago by anonymous

How could you overcome the zlib.h and iconv.h problem? I got those libraries built but not able to build samba3x still

comment:16 Changed 5 years ago by anonymous

Finally I done the followings in the Makefile in order to get it compiled,

added "include $(INCLUDE_DIR)/nls.mk"
added "DEPENDS:=+@BUILD_NLS +zlib" to Package/samba3x-common
added "$(if $(ICONV_FULL),--with-libiconv=gnu) \" to build options

comment:17 Changed 5 years ago by anonymous

I get lots of:

cc1: note: someone does not honour COPTS correctly, passed 0 times

while building your samba3x version.

comment:18 Changed 5 years ago by mystica555

I got this working just fine, with one exception:

Samba 3.6.0 is removed from the samba.org tree, replaced with 3.6.1, which includes a bunch of bugfixes.

Editing the Makefile to reference version 3.6.1, and removing '120_compile_fixes.patch' (the file is already fixed in 3.6.1 and thus the patch is rejected) makes it compile just fine.

I'm uncertain what is meant by the zlib/iconv bit from 5 weeks ago, I didn't have to modify anything in that regard.

comment:19 follow-up: Changed 5 years ago by Todd Richmond <todd_richmond@…>

Sorry - I've been swamped since 3.6.1 came out, but I'm upgrading to the most recent Openwrt right now and will work on updating my patch set within a few days. Removing the 120_compile_fixes patch is correct - I filed that bug with Samba and they close it fixed. I don't think there are many diffs for Makefile, but the control script might need to be updated to the new service interface that went into the most recent openwrt head.

I also get the cc1 warning - the fix wasn't obvious, but I'll try looking into that as well

How has it been working so far? Still a memory pig, but bearable on a newer gigabit router with plenty of RAM

comment:20 in reply to: ↑ 19 Changed 5 years ago by mystica555

Replying to Todd Richmond <todd_richmond@…>:

I also get the cc1 warning - the fix wasn't obvious, but I'll try looking into that as well

How has it been working so far? Still a memory pig, but bearable on a newer gigabit router with plenty of RAM

Its somewhere around 7 megs resident used, 32m virtual. Seems quite usable with 64 megs of ram.

I'm having a bit of an issue with a remote client using windows 7. I thought the lacking of nmbd from the 3.0.someother release from the main openwrt tree was at issue; this version with proper workgroup set and including nmbd doesn't seem to show up, granted, A: i don't think he knows where to look and b: i don't even know what win7 does anymore with regard to sharing...

This I'll take a closer look at likely via teamviewer this weekend.

comment:21 Changed 5 years ago by anonymous

And the entire thing I was trying to comment on I missed...

https://forum.openwrt.org/viewtopic.php?id=25306 seems to provide some insight on what that cc1 error is.

comment:22 Changed 5 years ago by mystica555

That last bit was me. I forgot once again to change my name in the user field above and realized as soon as i hit submit..

And this bug report system has a rather annoying bayesian filter...

comment:23 Changed 5 years ago by written

Okay. I updated and cleaned up the Makefile with jow_laptop's help.

Next is to update the init script to make use of the new service functions.

Once done, I'll attach an updated patch to the ticket here.

Changed 5 years ago by written

comment:24 Changed 5 years ago by written

Okay. It's done ;-)

  • clean up Makefile
  • update to 3.6.1
  • removed 120_compile_fixes.patch
  • refreshed patches
  • fix cc1 error
  • use new service functions in the init script

To apply and test the samba-upgrade.patch do the following in the toplevel build directory:

svn --force delete feeds/packages/net/samba3x/
wget -q -O - --no-check-certificate "https://dev.openwrt.org/raw-attachment/ticket/9992/samba-upgrade.patch" | patch -p0
svn add feeds/packages/net/samba3x
./scripts/feeds update -i packages
./scripts/feeds install samba3x-common
make menuconfig
make

Result is:

oliver@oliver-desktop:~/openwrt/trunk_2$ vdir -h ~/public_html/trunk_2/packages/samba3x*
-rw-r--r-- 1 oliver oliver 670K 2011-11-20 03:23 /home/oliver/public_html/trunk_2/packages/samba3x-client_3.6.1-1_ar71xx.ipk
-rw-r--r-- 1 oliver oliver 1.8M 2011-11-20 03:23 /home/oliver/public_html/trunk_2/packages/samba3x-common_3.6.1-1_ar71xx.ipk
-rw-r--r-- 1 oliver oliver 1.1M 2011-11-20 03:23 /home/oliver/public_html/trunk_2/packages/samba3x-server_3.6.1-1_ar71xx.ipk
oliver@oliver-desktop:~/openwrt/trunk_2$

Have fun with testing ;-)

comment:25 Changed 5 years ago by anonymous

I get an error when I try to compile samba3x using the commands of the comment before me. ("make package/samba3x/compile V=99")

./configure: line 4088: mips-openwrt-linux-uclibc-gcc: command not found
configure:4090: $? = 127
configure:4128: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "Samba"
| #define PACKAGE_TARNAME "samba"
| #define PACKAGE_VERSION "3"
| #define PACKAGE_STRING "Samba 3"
| #define PACKAGE_BUGREPORT "samba-technical@samba.org"
| #define PACKAGE_URL ""
| #define CONFIG_H_IS_FROM_SAMBA 1
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }

Have I done something wrong?

I really want Samba 3.6 on my OpenWRT box but I can't help with the programming. :(

comment:26 Changed 5 years ago by jow

You have no toolchain built yet.

comment:27 Changed 5 years ago by anonymous

Thanks jow. I thought "make" does that automatically.

I compiled the packages and installed them on a WZR-HP-AG300H.
Well, thanks a lot! Everything works fine! I am now able to use Samba shares from the router with my Windows 7 machine. With previous versions of Samba this wasn't working for some reason.
So far I haven't discovered any bugs.

Again: Thanks a lot! :)

comment:28 Changed 5 years ago by Todd Richmond <todd_richmond@…>

Thank you very much for fixing the top level makefile! This patch is getting very close - just a few more tweaks (full patch #3 attached at top of ticket)

One note - I personally have changed to use "passdb backend = tdbsam" due to limitations in smbpasswd (according to smb.conf manpage). This should probably be the new default, but I'm loathe to switch for people who use the old file

Stock 3.0.24 has VERY severe connectivity problems with Windows 7 with any kernel I've used in the last 4+ months. About 30% of the time I try to copy more than one large video file, the connection will abort. It usually works ok for small files, but copying a collection of videos is impossible

1) smbpasswd has been moved to /usr/sbin in official builds so now do the same

2) samba.config and samba.init need destination rename in Makefile

3) simplify Makefile by adding a PKG_BUILD_BIN var

4) a few minor tweaks to smb.conf.template

min receivefile size = 16384
remote announce = 192.168.1.255
reset on zero vc = yes
smb encrypt = disabled
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65535 SO_SNDBUF=65535

4) cleaned up the makefile quite a bit more to have consistent indent style

x) I'll be testing AIO later (have to quit today) to try getting past 16mb/s on my AG300H which is one of the fastest routers available

aio read size = 16384
aio write size = 16384
aio write behind = true

Changed 5 years ago by Todd Richmond <todd_richmond@…>

patch integrating compile time cleanup and other minor fixes

comment:29 Changed 5 years ago by anonymous

configure: error: in `/home/tux/cleanopenwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.32/samba-3.0.37/source':
configure: error: cannot run test program while cross compiling
See `config.log' for more details.

comment:30 Changed 5 years ago by Todd Richmond <todd_richmond@…>

That is a different problem - the main branch is being upgraded to 3.0.37 (this bug is for 3.6). 3.0.37 will be MUCH smaller than my changes for 3.6, but hopefully better than 3.0.24 which has very significant problems with Windows 7

At some point, me or someone else will have to review the AVM patches and how they relate to 3.6.1. The first thing I want to look at is removing an extra forked process and then removing some of the larger unused features. This will never be small router compatible however - I'm personally much more interested in performance and reliability on larger memory routers

Changed 5 years ago by Todd Richmond <todd_richmond@…>

more bug fixes, cleanup and size reduction - Makefile.in submitted to samba.org for review

comment:31 Changed 5 years ago by anonymous

There's still a small bug in "smb.conf.template" of the latest attachement (samba3x.tar.4.gz).

	reset on zero vc = yes
	remote announce = 192.168.1.255
	security = user
	smb encrypt = disableennounce = 192.168.1.255
        security = user
        smb encrypt = disabled
	smb passwd file = /etc/samba/smbpasswd

As you can see some elements exist twice and one line is completely wrong. Looks like a normal mistake after copypasting.

So I guesst hat chunk of code should look more like this:

	reset on zero vc = yes
	remote announce = 192.168.1.255
	security = user
	smb encrypt = disable
	smb passwd file = /etc/samba/smbpasswd

But still great work Todd!
I tried to connect samba3.0.24 to Windows 7 for so long. It almost never worked. And then you ported 3.6 to openwrt and everything immediately works.. awesome! Thanks a lot! :)

comment:32 Changed 5 years ago by anonymous

I need to learn to use the "Preview" button.

I forgot the last "d" in the word "disabled".
Again that chunk of code, but corrected:

	reset on zero vc = yes
	remote announce = 192.168.1.255
	security = user
	smb encrypt = disabled
	smb passwd file = /etc/samba/smbpasswd

comment:33 Changed 5 years ago by anonymous

This full featured Samba 3.6.x version works like a charm with win7 ;-)

comment:34 Changed 5 years ago by anonymous

Same here. Works with Win 7. Good job!

comment:35 Changed 5 years ago by nbd

I took this package as a starting point and made some heavy modifications. I turned smbd, nmbd and smbpasswd into a single multicall binary, disabled dynamic export and stripped a few useless features.

The result is a package that's about 5 MB uncompressed (which is actually less than just the shared library from the previous version) :)

I've worked on making the feature-removal patches as small and unintrusive as possible, so they should be easy to upgrade with future releases.

Thanks to Todd for the initial work and inspiration.

The result is committed in r30489, please test it and tell me if it works ;)

comment:36 Changed 5 years ago by anonymous

Thanks a lot nbd! I've waited for this a long time! :D

The default for "reset on zero vc" (in samba.conf.template) is the value "yes". Perhaps this should be "no" as default as it causes trouble in my network, for example a lot connection loss, aborting file transfers and similar annoying things.

"reset on zero vc = no" fixes that.

More detailed explanation:
Windows Vista/7 sometimes try to connect twice or more to the samba server, but it only accepts one connection per IP by default because of "security" (but in a local network an attacker is highly unlikely anyway, so it doesnt matter).
If windows tries to build a 2nd connection to the samba server, the server will reset all connections from that IP - even if it's in the middle of a file transfer or something else. It will just send an RST Packet without any other information.

This was a very annyoing problem and took me some time to find the cause.

Even more information are here: http://www.nynaeve.net/?p=93

comment:37 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

I've done some more optimization, uncompressed binary size is now down to 2.7M and it still works fine with Windows 7.

Next thing on my list is bringing its config in sync with the other samba package, tracked in ticket #10969. I will also look into the 'reset on zero vc' issue.

comment:38 Changed 5 years ago by Todd Richmond <todd_richmond@…>

removing reset on no vc completely is fine. The default is no and the man page was not completely clear so the option does not do exactly what I thought it does

2.7 MB is amazing! I'm out this week, but will try it out next week

Is your new diff against Samba 3.6.3? There were several fixes for SMB2

comment:39 Changed 5 years ago by nbd

Yes, I'm using Samba 3.6.3

comment:40 Changed 5 years ago by nbd

Apparently I wasn't done optimizing this thing. It's 2.1 MB uncompressed now, making it smaller than smbd+nmbd of samba 3.0.

comment:41 Changed 5 years ago by Todd Richmond <todd_richmond@…>

@ that size with a shared binary, it might not be worth having the separate samba-nmbd package. A config entry to disable nmbd startup could be simpler than two packages since most users wanting Samba will use nmbd - otherwise they have to connect everything via
ip.address instead of
string.name

Make sure to remove the reset on zero vc smb.conf.template if you took my patch since that seems to cause significant problems. The original smb.conf.template also used ISO8859 encoding instead of UTF8 which breaks foreign characters in file names. Mine fixed that along with fixing guest access

Finally, at some point it will be worth switching to "passdb backend = tdbsam" due to feature limitations in smbpasswd format. Could be worth doing now since 3.6 is such a big change that users have to recreate their smb.conf.templates files anyways for SMB2 support as well as all the other perf tuning

comment:42 Changed 5 years ago by nbd

Right, for multicall binaries the size difference between smbd+nmbd and just smbd is only about 100k.

As for the passdb backend, I recently sacrificed tdbsam support and replaced the smbpasswd tool with a rewritten version of the one we had in samba 3.0 (supporting only smbpasswd). The resulting binary size is now only about 1.7M.

I think most people won't need the extra features in tdbsam, and for those that do I can probably eventually add a compile-time option.

comment:43 Changed 5 years ago by pablo.alonso@…

Hi guys, After a research I have found this page with all of your fantastic work... I started playing with openwrt two days ago. This is wonderful!

I tried the samba 2 and 3 in the built-in packages of the openwrt firmware with a few problems... Now I have rearch this marvelous resource of knowledge, but is my lack of understanding that prevents me from putting this to work...

can anyone help me a little bit in a step by step how do I use last version provided here in order to get it working inside my router tplink wr1043nd with backfire 10.03.1.

thank you very much !
regards,
Pablo

Changed 5 years ago by alphasparc@…

Remove unnesssary socket options and cleanup smb conf template

comment:44 Changed 5 years ago by arokh <trondah@…>

I think a config option for startup of nmbd would be useful. I prefer using Avahi for discovery.

comment:45 Changed 5 years ago by anonymous

Add zlib dependency to package.
smbpasswd require zlib.

comment:46 Changed 5 years ago by nbd

zlib is no longer required, see r31048

comment:47 Changed 5 years ago by sniperpr@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

kernel 2.6.33.2 samba 3.6.3

toolchain-arm_v5te_gcc-4.6-linaro_uClibc-0.9.33_eabi target: kirkwood

help me . thanks.

error info:

kernel BUG at fs/locks.c:2036!

Unable to handle kernel NULL pointer dereference at virtual address 00000000
[ 39.680000] pgd = de564000
[ 39.680000] [00000000] *pgd=1e52e031, *pte=00000000, *ppte=00000000
[ 39.690000] Internal error: Oops: 817 #1
[ 39.690000] last sysfs file: /sys/kernel/uevent_seqnum
[ 39.690000] Modules linked in: fuse usb_storage usblp ohci_hcd xt_IMQ imq xt_DSCP xt_NOTRACK ehci_hcd pppoe pppox msdos tun ppp_async ppp_genb
[ 39.690000] CPU: 0 Not tainted (2.6.33.2 #8)
[ 39.690000] pc : [<c002d378>] lr : [<c005d450>] psr: 20000013
[ 39.690000] sp : de577ea0 ip : de577de0 fp : de577eac
[ 39.690000] r10: df53b598 r9 : df80ada0 r8 : df540b38
[ 39.690000] r7 : df540b38 r6 : df8f0f40 r5 : df8f0f40 r4 : df540bd0
[ 39.690000] r3 : 00000000 r2 : 60000013 r1 : 00003b50 r0 : 00000034
[ 39.690000] Flags: nzCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment user
[ 39.690000] Control: 0005397f Table: 1e564000 DAC: 00000015
[ 39.690000] Process smbd (pid: 1434, stack limit = 0xde576270)
[ 39.690000] Stack: (0xde577ea0 to 0xde578000)
[ 39.690000] 7ea0: de577f2c de577eb0 c00ea1cc c002d368 decceca0 df143d30 00000000 40021000
[ 39.690000] 7ec0: de577f34 de577ed0 c00a703c c00b137c 40022000 00000000 df8f0f40 00000000
[ 39.690000] 7ee0: 00000000 de577ef0 00000001 00001000 df540b38 00000000 00000000 df8f0f40
[ 39.690000] 7f00: df143a34 00000000 00000008 df8f0f40 00000000 00000008 df8f0f40 00000000
[ 39.690000] 7f20: de577f64 de577f30 c00b6198 c00ea0c8 00000000 00000000 000000ff de576000
[ 39.690000] 7f40: df8f0f40 ffffffea 00000000 000002b8 de576000 00000003 de577f74 de577f68
[ 39.690000] 7f60: c00b62dc c00b60f0 de577fa4 de577f78 c00a7474 c00b62b8 00000001 00000000
[ 39.690000] 7f80: 00000005 00000000 001af880 000000c0 c002a224 befee900 00000000 de577fa8
[ 39.690000] 7fa0: c002a0a0 c00a73c0 00000005 00000000 00000000 000002b8 00000003 00000001
[ 39.690000] 7fc0: 00000005 00000000 001af880 000000c0 00175e18 00175e90 befee900 befee904
[ 39.690000] 7fe0: 00000000 befee860 00173a14 4018cdd4 40000010 00000000 00806031 00806431
[ 39.690000] Backtrace:
[ 39.690000] Function entered at [<c002d358>] from [<c00ea1cc>]
[ 39.690000] Function entered at [<c00ea0b8>] from [<c00b6198>]
[ 39.690000] r7:00000000 r6:df8f0f40 r5:00000008 r4:00000000
[ 39.690000] Function entered at [<c00b60e0>] from [<c00b62dc>]
[ 39.690000] Function entered at [<c00b62a8>] from [<c00a7474>]
[ 39.690000] Function entered at [<c00a73b0>] from [<c002a0a0>]
[ 39.690000] Code: e1a01000 e59f000c eb0bb72c e3a03000 (e5833000)
[ 39.700000] ---[ end trace 6dff7b1c5c2681f5 ]---
[ 39.740000] VFS: Close: file count is 0

comment:48 Changed 5 years ago by todd_richmond@…

A kernel crash won't have anything to do with Samba which is a user space process. This is some issue with the USB driver

The only current issue I know about for samba 363 is that the config and init scripts need changing so I filed bug 10969

comment:49 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:50 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.